Cant integrate Telldus Live

My TelldusLive devices stopped working about a week ago. Tried to remove/add the integration but with no luck.

It seems like several people having trouble once a year when the token for TelldusLive expires. There are som old posts about this but it seems to be fixed in newer versions, but not for me.
Running 2021.1.5.
When i click Configure in the integrations page I get to choose cloud or local, the result is the same not matter what I pick.
All I get is a Send button, but clicking it only generates the following in the log:
[tellduslive] Failed to authorize: 403 Client Error: Forbidden for url:
Sometimes I also get:
[tellduslive] Failed to authorize: Token request failed with code 401, response was 'OAuth Verification Failed: Can’t exchange request token


I did this reinstallation last week due to I hadn’t added that the token should be renewed.
So what I did was to delete the integration and the tellduslive lines I had in the configuration file, so that every trace of Telldus is removed. Took a reboot, then added the telldus to the configuration file.


Telldus is then discovered as you also described. I use the local option, so this one send you to your Telldus gateway (which should be the same IP as in the configuration line), which you have to log into and her you get the choice to pick the token period and if it should be renewed. Once this is done, go back to Home Assistant and press send and the integration starts to collect the information from Telldus.

Unfortunately it does not help to remove/add the lines from configuration.yaml. As before, I get to choose between local/cloud, but after that the Send button just keeps on repeating

Is there a way I can manually remove all traces?

I changed the URL from where I started the integration to the external URL and voilá, it works.

Where y started. Can you explain?

I know it has been a while, but I’m experiencing this issue now when I triy to reenable Telldus Live. What do you mean with “changed the URL from where I started”? I tried to change the IP-adress in the URL to, and also without any success… :frowning: Any clues are highly appreciated as the WAF just dropped remarkably.

After struggling on and off with the Telldus integration, I was finally able to make it work with local access by authenticating with FIREFOX browser, having tried with Safari (that used to work) and Brave.