Can't log in with Windows but CANwith apple Mac

Just starting out with Hassio. looks exciting but…

For some reason I am unable to log in to Hass from my Windows desktop but Can using my Appl Macbook Pro.

I have a standard installation on a Raspberry Pi 3B

Does anyone have any idea why this would be.

Are you trying to use the EDGE browser? Try with Chrome or Firefox

Thanks for helping.

It’s the same in all three browsers. It is fine on the ipad as well.

I have cleared browsing data on all three browsers and reinstalled Chrome with no change. I have also rebuilt Hassio several times.


Check that you can ping the ip address or hassio.local from your windows machine. You can also try accessing hassio with the ip address i.e. http://192.168.x.x:8123 instead of http://hassio.local:8123

I just tried that. In all cases I get the login screen, in about twenty seconds I get a small HA icon in the middle of the screen with a message underneath that say “Unable to connect to home assistant…retry”

Did you check the log from your Macbook? It might be a hint there. It’s in the developer tools menu on the left.


Not sure how to do that or what to look for.

I have also started my Hass from Windows in Parallels on my Mac. Works great there too. Its got to be my Windows desktop.

Oh got your suggestion. I checked the log and the message is:

“Disconnected: Did not receive auth message within 10 seconds”
“components/ (WARNING) - message shows up 5 times”

Thats how many times I have tried from my desktop.

Any idea what that means!

Glad you have helped me so far.

Something might be blocking the websocket connection. Not the best of ideas, but try disabling your windows firewall temporarily and see if it helps. Which version of Home Assistant are you running? You can find it on the dev tools info page. Is the log you posted the entire log? You can get the full log by pressing a button at the bottom of the log page.

Your my new best friend lol

That did it. It wasn’t the Windows defender but the Total AV web shield that I had installed.
Now the issue is how to get around it. I have white Listed http://hassio.local:8123 and http://hassio.local:8123/lovelace with the same result. If you have no ideas I will get on to total av.

Thanks Again

See if Total AV has any log of blocked access and see if you can allow the blocked ports/ip.

Hi Tomas

I have been online with Total AV and they are at a loss. So I will uninstall the app and stay with Windows defender. What do you do\ for web protection? I asked them your question and they couldnt answer it.


I use as an adblocker and Symantec endpoint protection on my laptop. I also use to secure Home Assistant.

1 Like

I’m the same as @tjntomas with everything except the pi-hole.

1 Like