Can't login in to Node-RED


#1

Hello all,

I can’t login to Node-RED.

Have installed the addon with home assistant on a Raspberry Pi 3 and followed the configuration steps as described on the addon-node-red github page.

There are no problems in the log when running node red and the web UI login screen is reachable.

When filling in the user name and password and hit the login button. The login screen keeps refreshing and the username and password field are blank again, there were no login errors.

It’s not possible to get pass the login screen.

I tried it with Firefox, Chrome and IE, but with no success.

Has anyone encountered the same problem and found a solution?


Community Hass.io Add-on: Node-RED
Community Hass.io Add-on: Node-RED
#2

Hi,
Just to let you know - I have the same situation and trying to find a solution.
Unfortunately didn’t find it yet.

I just installed it and made all the settings. According to log - everything is working fine.
The situation is exactly as you described.


#3

Same for me :frowning:


#4

I have used this sequence and it worked for me

$ sudo apt -y update
$ sudo apt -y upgrade
$ sudo raspi-config
– config hostname
– config timezone
– enable ssh

$ sudo shutdown -r now
login via ssh

Now install npm & n

$ sudo apt -y install npm
$ sudo npm install -g n
$ sudo n stable

Now nstall node-red

$ bash <(curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered)
$ cd ~/.node-red
$ npm rebuild

Now setup Autostart on boot

$ sudo wget https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/nodered.service -O /lib/systemd/system/nodered.service
$ sudo systemctl daemon-reload
$ sudo systemctl enable nodered.service
$ sudo shutdown -r now

>avoid external calls to ha

Now install samba

$ sudo apt install samba samba-common-bin winbind
$ sudo mkdir -m 1777 /share
$ sudo nano /etc/samba/smb.conf
workgroup = WORKGROUP

[home]
Comment = Pi shared folder
Path = /home/pi
browseable = yes
writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
Public = yes
Guest ok = yes

[nodes]
Comment = Pi shared folder
Path = /home/pi/.node-red
Browseable = yes
Writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
Public = yes
Guest ok = yes

$ sudo /etc/init.d/samba restart

Now install webmin (light overhead but useful)

$ sudo apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python
$ wget http://prdownloads.sourceforge.net/webadmin/webmin_1.890_all.deb
$ sudo dpkg --install webmin_1.890_all.deb


#5

But you are not running HASSIO and the add-on, like the others have stated…your setup is 100% different than theirs.


#6

yeah, thats right … missed that part.

On the other hand … NR is working absolutely smooth for me (had the Add-on version before)


#7

Me too. I use docker containers and don’t mess with hassio. I see a lot of issues around here regarding hassio.


#8

Thank you for replying,

Found the problem…

Somehow my virus-scanner (Bitdefender) was blocking traffic from http://hassio.local:1880 without informing me.

I added a rule to allow traffic from http://hassio.local:1880 and problem solved.


#9

Thanks Owi! Perfect!
I’m also using BitDefender and noticed after your comment that it blocked traffic 86 times without any info! (sic!)

By the way I see that there are rumors regarding Hassio, but this time you cannot say hassio fault.
I must say the Home Assistant project is great and hope it will keep on growing!


#10

No antivirus software and no adblock add-on but facing same situation with @Owi . Is there a way to install any packet manager (like apt, yum) to hass to install node-red manually? Or any solution suggestion?

Edit:I couldn’t find a way to add an exception on firefox but, both Chrome and Opera can login to node red.


#11

I have Node-Red installed on a dedicated RPi and have no access issues with HA or other network components


#12

No. That’s not how docker works.


#13

This issue drove me crazy, kept typing my user and pass from my Node RED config. For some reason this works the first time you load node red. Once you reboot, you need to login to Node RED with your user and pass for your Hass.io install. Giggity! Good luck, hope that helps. Drove me insane for an hour.