Can't make new smartphone to work like it should

First of all, at this moment I can’t use https cause my internet-provider is blocking a lot of ports and I cant do any NAT-loopback.

That said.

On my phone and an old phone I have these settings that works great within the app to connect:

Home Assistant Url:

Wifi SSID: ‘The right name’

Internal URL: http://192.168.x.x:xxxx/

These settings work great on both devices both when I’m at home and when I’m outside/away.

Now we have a new phone and I put in the same as above, but it won’t work. If I put it in like the settings above: I can enter HA on the phone when I’m NOT on the WIFI.

If I do change the first line to be also the http://192.168… address I can only enter when I’m on the Wifi (makes sense).

Any ideas how I get this phone running like the others? :slight_smile:

I also have issues with the app.
If I enter my wifi in the app then I can’t connect, if I remove it then it works.

So try to remove everything that is not essential.
Meaning just keep the external address (duckdns) and remove wifi and internal ip.

The problem is that I can’t connect to the duckdns link when I’m on my wifi. This cause there is no nat-loopback.

Not even with the browser on the phone?