Can't mount NAS folder under /media (worked previously)

After updating the QNAP Nas to 5.0.1 and HA to 2022.9.x my drive mapping has stopped working.

I’ve tried both via CIFS and NFS, but noo dice.

mount -t nfs4 a.b.c.d:/Multimedia /media/nasfiles
mount: mounting a.b.c.d:/Multimedia on /media/nasfiles failed: Permission denied


mkdir -p /media/nasfiles;mount -t cifs -o vers=3.0,noserverino,username=user,password=pass,domain=WORKGROUP //a.b.c.d/Multimedia /media/nasfiles

But I just get a Permission Denied.
I can mount the drive from a PC for the CIFS, and another linux for the NFS.

Any ideas for this?

Take the vers 3.0 and the noserverino out…helped me

Nope, doesn’t work either

mount -t cifs //a.b.c.d:/Multimedia/MP3 /media/nasfiles/ -o user=user,password=pw
mount: bad port ''
mount: mounting //a.b.c.d:/Multimedia/MP3 on /media/nasfiles/ failed: Result not representable

And that’s a really weird error?


This i my mount command that works for me…
In configuration.yaml
Mount_nas: mkdir -p /media && mount -t cifs -o username=xyz, password=xyz, domain=workgroup //nas_ip/sharename /media

This way you can use the mount as a service on autostart or such, but try if this syntax does work for you

I got it working again, weird behaviour, the official SSH addon doesn’t allow the mapping, giving a permission denied, but the community SSH addon works.


  mount_nas_folder: mkdir -p /media/nasfiles;mount -t nfs4 -o ro IP-OF-NAS:/Multimedia/MP3  /media/nasfiles

But as I haven’t rebooted the entire host, I’m not sure if the automation maps it, or if it just reusing the mapping made throught the HA Community AddOn?