Can't move data only to SD Card on Khadas VIM1s

A recent HA 2023.10.1 working fine on Khadas VIM1s hardware.

BTW - Happy to be able to make our house ‘smarter’, that works like a charm, thanks to all who participate to this project!

But I can easily predict I’ll be out of space for data soon, so I bought a brand new Sandisk 128GB Extreme Pro SD, inserted in the Khadas.

I wish to move only the data.

I tried using the lovelace UI:

2023-10-11 21_48_48-Paramètres – Home Assistant — Mozilla Firefox

The lovelace log shows:

2023-10-11 19:36:10.979 ERROR (MainThread) [homeassistant.components.hassio] Failed to to call /os/datadisk/move - ‘DataDisk.migrate_disk’ blocked from execution, no Home Assistant OS available

I installed Terminal/SSH on the UI:

ha os datadisk move /dev/mmcblk1
Error: ‘DataDisk.migrate_disk’ blocked from execution, no Home Assistant OS available

I then tried what I’ve found reading:

gdbus call --system --dest io.hass.os --object-path /io/hass/os/DataDisk --method io.hass.os.DataDisk.ChangeDevice "/dev/mmcblk1"

Error: GDBus.Error:org.freedesktop.DBus.Error.Failed: Expected single block device with file system label “hassos-data”, found 0

I’m a bit desperate, I thought this would take a few minutes (couple days data only), and I’ve already spent the afternoon searching :frowning:

The SD card is working very fine, measured reading 79.4MB/s on /dev/mmcblk1.
I tried destroying all partitions on this SD Card on Windows (Minitool Partition Wizard), then reboot the Khadas. Didn’t change anything.

Thank you for any help - can provide you with any info you’d need. Thank you!

1 Like

More ‘random’ info, in case of:

[core-ssh /]$ ha os datadisk list

  • SR128-0x7dd13e48
  • dev_path: /dev/mmcblk1
    id: SR128-0x7dd13e48
    model: SR128
    name: SR128 (0x7dd13e48)
    serial: “0x7dd13e48”
    size: 127865454592
    vendor: “”

Informations système

Version core-2023.10.1
Type d’installation Home Assistant Supervised
Développement false
Supervisor true
Docker true
Utilisateur root
Environnement virtuel false
Version de Python 3.11.5
Famille du système d’exploitation Linux
Version du système d’exploitation 5.4.180
Architecture du processeur aarch64
Fuseau horaire Europe/Paris
Répertoire de configuration /config

Home Assistant Supervisor

Système d’exploitation hôte Debian GNU/Linux 11 (bullseye)
Canal de mise à jour stable
Version du Supervisor supervisor-2023.10.0
Version de l’agent 1.5.1
Version de Docker 24.0.2
Taille total du disque 14.4 GB
Taille du disque utilisé 6.4 GB
Sain true
Prise en charge true
API du Supervisor ok
Version de l’API ok
Modules complémentaires installés Mosquitto broker (6.3.1), Zigbee2MQTT (1.33.1-1), Samba share (10.0.2), Terminal & SSH (9.7.1)

System, hardware



DEVLINKS: /dev/disk/by-id/mmc-SR128_0x7dd13e48 /dev/disk/by-path/
DEVNAME: /dev/mmcblk1
DEVPATH: /devices/platform/soc/
ID_PATH_TAG: platform-fe08a000_sd
ID_SERIAL: ‘0x7dd13e48’
MAJOR: ‘179’
MINOR: ‘0’
TAGS: ‘:systemd:’

Did you find any solution ?
I have the same issue with Khadas VIM1S (with sd card or usb drive…)

Thank for any help