Can't open video stream from ONVIF

I have two ONVIF cameras. They worked fine until some recent release. I can’t tell precisely after which update they stopped working.

Currently I’m running 0.114.1. I can see the picture from the camera (using lovelace widget). But I can’t open video stream anymore. Here is the error:

Logger: root
Source: components/stream/
First occurred: 12:40:43 AM (10 occurrences)
Last logged: 2:02:00 PM

Uncaught thread exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/", line 932, in _bootstrap_inner
  File "/usr/local/lib/python3.8/", line 870, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/src/homeassistant/homeassistant/components/stream/", line 49, in stream_worker
    container =, options=stream.options)
  File "av/container/core.pyx", line 354, in
  File "av/container/core.pyx", line 225, in av.container.core.Container.__cinit__
  File "av/container/core.pyx", line 257, in av.container.core.Container.err_check
  File "av/error.pyx", line 336, in av.error.err_check
av.error.OSError: [Errno 5] I/O error: 'rtsp://admin:[stripped]@'; last error log: [tcp] Failed to resolve hostname admin: Try again 

SOLVED: ffmpeg does not support passwords with “#” symbol. I changed the password, and streaming now works.

Surprisingly, passwords with “#” worked until the most recent update.