Can't pair LG TV via LG Integration

I’ve set my modem in bridge mode and now only my router acts as DHCP, it was a bit of a hassle because I set up my pi with a static IP which i forgot to remove. After setting a new static IP and forwarding the 443 port to it, everything is working fine! :smiley:
Now it’s time to learn some automation :stuck_out_tongue:

EDIT: I think I’m finally getting somewhere, for some reason I can’t ping the TV when on a wired network. The TV is wireless and my Pi is wired, will update this topic with my findings.

EDIT2: Feel free to close this post. I know what the issue is, but it’s going to take some time for me to resolve this. Currently my wired modem acts as a DHCP for the wired network, giving out addresses in the x.x.178.x range. My router is also a DHCP, handing out addresses in the x.x.68.x range, I think this is the reason why some devices can’t connect. Any network specialists out there, feel free to help me :stuck_out_tongue:

Hi all,

Same as for most of these LG TV topics, I’m a newcomer as well.

At first I started with running Home Assistant in a docker container, but couldn’t get remote access to work so I started over with HassIO on my RaspBerry Pi 4.
When I was running HA in a docker container, I did manage to:
Add the LG WebOs integration and it auto-discovered my LG C1, after of course enabling the Mobile setting on the TV.

However, now I can’t seem to get the pairing to work and I tried a lot of things, this is the issue:
In HA I go to Settings > Integrations > Add Integration and search for the webOS integration.
Next, it asks me for a Host and Name, so I fill in the IP address of the TV:
I leave the name empty since I saw this worked for others in other topics.

Now, I get the WebOS TV Pairing option, after pressing submit it spins for a bit and then I get:
Failed to connect, please turn on your TV or check ip address

I am able to ping the TV, I have disabled and restarted all my devices but to no avail.

Any idea what I can do here?

Disable one of the DHCP server and check that all devices get an ip address in the same range.

1 Like