Can't pair TS011F plugs anymore

Hi All,

I have 8 of these TS011F (Nous) plugs connected to a SonOff USB3 plus-E dongle. They worked fine for a few weeks now.
For some reason a plug loses connection and won’t come back online. Also not when placed in a different wall socket.
Deleting the device from the ZHA integration and trying to re-pair by holding the button for 10sec. gave no result. It just won’t show up when looking for new devices.

Now I have 3 dead plugs without connection. They do switch fine with the local button but I can’t pair them anymore.
Where should I start debugging this?
Anyone with tips or ideas?


I had a similar problem. I’d like to follow the thread to find out the solutions of the problem

Same here, also following

I noticed that renaming them in HA is one of the problems.
After giving them a new name the connection is lost and any attempts to re-discover them are futile.

Any solution guys? I have the same problem. I have reset the plugs adding them to Immax Neo HUB where they appeared fine. However it is also weird that one of the plugs were connected via the other in home assistant and it could join or couldn’t be reset until the other became online. Wiping them the opposite order of the original connection order was solving the reset, but still cannot link them to HA.

Same problem with the same setup. “Glad” it’s not just me as I’ve tried buying new plugs from multiple sellers assuming it was something wrong with the plugs as the ones I’ve bought months ago still function absolutely flawlessly. Now I’m worried that basically my whole setup will go down for good once the electricity goes out even for a moment if the plugs won’t come back once powered off.

Would try with Z2M but it has never worked with the dongle in the first place.