Cant play a spotify playlist

hi,

the spotify integration seems to work (no errror and “detects” a spotify premium)

so i tried a simple script:

spotitest:
  alias: 'Playlist'
  sequence:
   - service: media_player.play_media
     data_template:
       entity_id: media_player.hobbyraum
       media_content_id: 'spotify:user:spotify:playlist:2jzSk9JuA1aikOVUZFfXFf'
       media_content_type: 'playlist'

media_player.hobbyraum is a google home wich make the “activated sound” when i run the script and nothing more

From an automation I have. (it’s a touch problematic. still tinkering with it.)

action:
    - service: media_player.select_source
      data:
        entity_id: media_player.spotify_myusernamehere
        source: asourcefromSpotify
    - service: media_player.play_media
      data:
        entity_id: media_player.spotify_myusernamehere
        media_content_id: spotify:playlist:5YLZml89bXSdsfdsotNy
        media_content_type: playlist

the spotify playlist uri I got from a right click on the playlist, share, copy spotify uri.

The source selection I can see in the spotify card

i want to use the speaker as playback device, so that wont work, sorry :frowning:

If you can use the speaker with spotify, it’ll be there. Or should be. My echo dots show up. That’s what the select_source is for.

Doing a little research

It looks like you can’t cast using spotify connect, which is what this uses.

I think that because you don’t regularly update new versions, you can’t play playlists. I used spotify premium apk android latest version so there is no error