Can't pull docker image

docker pull homeassistant/home-assistant
I’ve tried getting this image various ways pulled as above
docker run, docker-compose but I keep getting the same error message.

Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:42869->[::1]:53: read: connection refused

I don’t have any issues with other images

Anyone have any ideas what the problem could be.

Thanks in advance
Tonyek

I’ve seen an error similar to this around the web. I think they typically change DNS settings and it fixes it. Obviously, the process differs from OS to OS.

Hi thanks for your reply I had seen this as well and changed my dns from 1.1.1.1 back to 8.8.8.8
but still the same . Plus i can get any other image , the problem just seems to be with the home assistant image. But I’ll try few more dns changes to see if that works.

Tony

Stupid question…did you reboot the host?

Beyond that, I’m no expert on Docker but, here’s what I have tried when I’m typically troubleshooting Docker in Linux.

Check to see if it’s running (probably not running):
docker ps -a

If it’s running, stop it:
docker stop ImageNameHere

Unload the image from Docker - if it exists and it’s not running:
docker rm ImageNameHere

See if the image is still available to load:
docker images -a

If you find it, get rid of it:
docker image rm ImageNameHere

Worst case, prune it but be careful with this command; it will flush pretty much anything that’s not running:
docker system prune

Thanks again but the problem is downloading the image from the repository.
For some reason I’m not getting allowed in to get it ?

I had a similar problem on portainer, which seems to struggle with large images. If you do a docker pull that will work, I eventually installed watchtower to do it for me

Thanks I just had another go and it’s came in find . Beginning to think the repository was down
for maintenance or something. I’ll have a look at Watchtower. :+1: