Can't remove old test-app from google home

Hi! I have hade some problems with my manual config of google assistent support so I started from beginning. The problem is now that I can’t remove the old “test-app” from my google home application. It just says “Unable to update setting, check connection”.
Any Idea?

Have you deleted it from the cloud console? Even after you remove it and unlink it it may sit there for a few minutes/hours until everything gets updated and synced.

Yes. I deleted it from Google Cloud console but after 24 hours it’s still where and I can’t unlink it.

It’ll sound stupid but just keep doing it. The Google Home app is kinda glitchy. It should eventually allow you to. Are you actually going into “Home Control>Manage Accounts” and unlinking it that way?

I do it from that view.
Tried the whole day without any luck.
The new service works perfect. I can link and unlink.

Glad you got it worked out.

The problem is now that I have duplicate light,switches and so on and google assistent tries to connect to the old service (the one i want to unlink).

They should disappear eventually. I had the same issue and it was a sync thing. Eventually the duplicates disappeared. I’m pretty sure it has something to do with the new Google Home App.

Did you delete the old project on actions on google?

yes. I started over from scratch. I couldn’t get things to work otherwise after migrating to 0.80

Yesterday my old project moved down to avalible smart device. Hope it will disapear after some more days.

sorry to dig up this old thread but i have apps that are no longer in Actions or Cloud on Google and they still show up after more than 6 months… any ideas on how to get them removed?

Same issue for me

Same issue eventually will have 100s of them :joy::joy:

Hello, same issue here.
Any ideas after 4 years since this topic was created?

nope, never had it fixed, it’s so stupid :slight_smile:

The solution for me was to just create a new “home” in Google Home and then delete my original home. Afterwards, I reconnected with my HA test app and imported all my devices just fine. Besides putting devices back in their appropriate rooms, was actually easier than I thought.

Two things to consider though if you want to try this:

  1. If you have other members in your current “house,” make sure to have them all leave the house in order to fully delete it. Otherwise, you won’t have permission to move some of your devices (especially Google/Nest ones) and they’ll be stuck in the old home.
  2. If you have any Google Home automations or routines, those will not move over to your new home. Make sure to write them down in order to re-create them later!

yep found this one out when you delete one and add one back with the same name, they just stay no matter what.

solution: new ones blah 1, 2, 3 etc :joy: oh well.

got this still here. multiple of the same name… this has not been fixed yet. Awfull