Can't see HA VM on my network

Hi there,

I’m trying to setup outside access and Google Assistant on my HA server, but getting to the port-forwarding part of it, I can’t see the HA VM amongst connected devices on my network… and thus can’t setup the port-forwarding.

I’m new to HA. I’ve installed the last (7.2) VM version of it on VirtualBox, running on an old Windows PC (freshly installed with Win11).

The PC is connected to my home network through Wi-Fi, although I do know it’s not ideal.
My home network is as such :

  • I’ve got a router from my internet provider that connect to the internet (I live in in France, and every internet provider gives you a default all included modem/router with any subscription).
  • This router’s wifi is turned off, it connects via ethernet to a TP-Link DECO9 router, meshed across my home with two additionnal DECO9 units. The TP-Link Deco9 network is the actual network everything connects to.

I’ve encountered a strong delay problem with the install : HA was “preparing” for more than an hour before getting to the onboarding screen. But it finally got there.

Now, during that preparation process, I could see the HA VM IP address showing up on my network, in the TP Link app, and available for port-forwarding, and it was named “wlan0”.

But after the onboarding was complete… it just disapeared from the network. The wlan0 device shows as disconnected on the TP Link app, and no other device appears, with the dedicated local IP adress.

When running, I can perfectly reach my HA dashboard both with homeassistant.local:8123, and the local IP address like such : 198.168.XX.XXX:8123, from any other computer that is connected on my network. I can set it to static and change it no problem in the Supervisor, it always works.

But it won’t show on the TP Link Deco app anymore, and there is no override to set manually the IP address for port-forwarding.

I tried tinkering with the DNS, setting it to 8.8.8.8, then 1.1.1.1, then my router DNS again, but nothing changed.
I’ve tried nuking the install and reinstalling it completely vanilla, but I got the same result.

Does anyone have any idea how I could solve that ?

Thank you very much for your help…!

I’m confused, the title of this thread is “Can’t see HA VM on my network” but then you right the above?

Is it that you can’t see the VM in TP Link Deco app?

Yes, to rephrase, the VM connects to my network, I can reach it across that network, but it doesn’t show as a connected device on the TP Link Deco interface.

Which is very weird because very much anything else I’ve ever connected does show up, even weird chinese iot devices…

Did you managed to solve this? I’m facing the same issue, only that I’m using Google nest wifi instead of the Tp-link.

I too am having the same issue with my Deco P9 system. The TP-link app requires you to first see the IP address of the device before you can select it for port forwarding (I’m trying to setup remote access)… I won’t lie, I’m have endless hassles with my Deco system which is missing basic router configuration settings and other features available on their other (more cheaper) TP-link devices…

Also using nest wifi, having the same issue here.

One thing I noticed however is that a device called “pywemo virtual device” exists on the list and sometimes has the same ip address of my home assistant instance. However when I click off of it and click back on it, the ip address changes.

The interface imo is just plain bad for this sort of stuff, would much rather do this on my computer than my phone.

I’m having this same issue. TPLink Deco router, Hyper-V instance and my host machine is Windows 11 on a wifi connection. I’m thinking if I hardwire this issue might go away but I haven’t gone that far yet. Because the virtual machine does get a proper IP address I have to believe that it’s getting it from the TPLink router but for some reason the router isn’t showing it as a device when I try to set up port forwarding thought I can see the host machine. My Deco router is supposed to notify me when a new device connects to the network as well.

I have also noticed that the HA server seems to lose network connectivity after a short time, maybe an hour or so of running. The VM still runs fine, I just have to restart it but I’m suspecting what I actually need to restart is the network. So it seems it may be getting an improper DHCP lease of some sort.

Just as a follow up, I hardwired my machine to the router and it works now. I can see the Home Assistant virtual machine on the Deco router app.