Can't see IP camera?

I am probably missing obvious… I have a generic IP camera on my home network, and I can see it on any browser by entering:

It looked pretty straightforward, I put this into my configuraion.yaml file:

  - platform: mjpeg

So, what else do I need to do? When I reboot, there is no card, no view, no tab. What am I missing? (Newbie question).

Steve Mann
[ Raspberry 3,, Home Assistant Version 0.72.1]

is it showing up as an entity in your ‘states’ list? should be something like “camera.xxxx”

What else should I check?

Any errors popup?
Silly question, but are you sure you saved the configuration.yaml and restarted HA?


I would have sworn that I rebooted because I typically reboot after every configuration.yaml change. (I am not experienced enough to know when “reload core” is sufficient). But on the chance that I hadn’t, I rebooted.
Now I am seeing camera.mjpeg_camera in States, and the camera view on the overview-Home page.

(Old software engineers never die, they just reboot.)

But your assistance is greatly appreciated. My next challenge is to get my Amcrest camera to work in Home Assistant.


another point based on your answers above is that there is no need to reboot your HA machine after a configuration change. just restart the home assistant service.

Would that be homeassistant.restart? Certainly faster than rebooting the Raspberry Pi.

If so, can I make a feature request to add this to the Configuration reloading on the General configuration? I am already on that page to do a configuration check.

You can do it from configuration panel>general page. Its at the bottom of that page.

Honestly, though it’s almost never worked for me. I’m not really sure why but every time I try it says something like “error calling service”. Give it a shot tho. It might work for you. Otherwise I always seem to use putty to restart from the terminal.

Sudo systemctl restart [email protected]

Doesn’t that button reboot the Raspberry Pi? Clicking that disconnects my SSH into (on a putty terminal or sftp in Filezilla) and it takes two or three minutes to fully restart. Running the homeassistant.restart service does not reboot the Pi.

I guess I’m not sure. I didn’t know you were using hassio (obviously I didn’t read the category). I’m not sure how that works compared to hassbian.

I couldn’t get Home Assistant to work on a Raspian system with Node-Red, and before completely giving up, I just downloaded the image file and have subsequently been stumbling my way to proficiency. I have a long way to go…

Most of my home IOT is on Node-Red and consists of a bunch of Sonoff-Basic modules and a few ESP8266 kits in various places. I decided to add some Z-Wave, and everyone on the Node-Red forums insisted that Home Assistant is the best interface with Z-Wave. So, that’s how I was dragged kicking and screaming into the Home Assistant word. But the more I learn to use Home Assistant, the more I appreciate it.

Again, your assistance is appreciated. Next, I am going to try to get more of my cameras into Home Assistant.

Steve Mann

My job has taught me to always start looking for the silliest things to start from, then go to the complicated ones even though I have failed to do this for myself sometimes. Well, I am glad you sorted it out.

When you restart HA it says “Failed to call service homeassistant/restart.”
This is absolutely normal. It actually means that HA is shutdown.


No, It just restarts the HA service.

What I have done to make sure it is restarting, is to use automations when service shutdown and restart occur. So everytime HA is restarting I am getting notifications (I use TTS in my home) when it shuts down and also when it is up and running.

My Home Assistant on does not behave as you describe.

When I restart HA through “services”, I get no error messages, and the restart takes seconds.

When I click on Server Management/ Restart, I get a “Service lost, reconnecting” message, my SSL connection is broken, and the host (a Raspberry Pi3) reboots. And the restart takes a couple of minutes.

Oh, OK. Thanks. I didn’t realize that.

I could have swore that I used it a few times several months back and it didn’t do that.

And when i restart the service from putty I get a “connection lost. reconnecting…” message for several seconds (~10 seconds?) while the service restarts. if I restart it from the GUI I don’t get that message. So I assumed it wasn’t working. That seems like kind of a confusing way of doing things tho. I’ll have to make a change and test it out.

I have 2 generic IP cams that I can’t figure out how to get set up in HA. How did you find your URL for your camera?

Mine works in the app, but I can’t find anything beyond that.

I use static IP for all of my cameras, but this is something everyone should have in their toolbox:

You can sort by manufacturer to identify your camera, or sort by IP and unplug the camera to see which IP goes away.

Steve Mann

Oh, I didnt know you are on I am on raspbian and it behaves like that. Sorry about that.

I wish we had a sig capability on this forum. That would certainly clear up some discontinuity.

Steve Mann
[ Raspberry 3,, Home Assistant Version 0.72.1]

1 Like

You just gave me the idea to use this as my signature! I am going to see if we can do this. Is there a signature option on this forum? Gonna check it.

I dont see how we can do this… Anyway. To get back at your original question, you said you wanted your amcrest camera to work. You shouldnt have any problems with that since there is already a component for that, so you dont need any mjpeg setup for it. Tell us how it goes.