Cant seems to find SSH in the Hassio Addons Page

I am running Hassio on a new Raspberry Pi 4 and installed the latest version - 109.3. However, I am unable to find and install SSH in the Addons Page. I have tried to reformat the sd card and install hassio again but still no SSH in the Addons Page. Please help!

SSH is now for ‘advanced’ users only. Click in the lower left corner on your name, and enable advanced mode. Then you will be able to see the SSH add-on.

image

1 Like

Sorry but that has to be one of the dumbest decisions in the long line of recent dumb decisions. How are new users supposed to recover from a failed front end?

It’s not safe/recovery mode. That never works.

I know, but I don’t make the decisions.

1 Like

Thanks @francisp for the quick response! Yes, I have found it! On to my setup.

Yeah I wasn’t blaming you.

Hi @francisp,

I have the following error with the SSH:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] cli: applying... 
[fix-attrs.d] cli: exited 0.
[fix-attrs.d] profile: applying... 
[fix-attrs.d] profile: exited 0.
[fix-attrs.d] ssh: applying... 
[fix-attrs.d] ssh: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] keygen.sh: executing... 
[05:38:09] INFO: Restoring host keys...
cp: can't stat '/data/host_keys/*': No such file or directory
[cont-init.d] keygen.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

I am unable to start SSH at all with the default configuration or with my own config as follows:

authorized_keys:
    ssh-rsa XXX..... rsa-key-20190209
password: ''

took me 30 minutes to figure this “advanced mode” out … this is complete bullshit… finding the right usb mount is not really advanced. at least not until it’s not listed anywhere in the UI