Can't start hassio anymore


I installed hassio with docker and since yesterday it worked fine. Today, without modifying anything, I can’t start hasssio, and from the docker’s log, I see:

19-04-25 12:20:22 ERROR (SyncWorker_4) [hassio.docker.interface] Can’t install homeassistant/armhf-hassio-supervisor:162 -> 404 Client Error: Not Found (“no such image: homeassistant/armhf-hassio-supervisor:162: No such image: homeassistant/armhf-hassio-supervisor:162”).
19-04-25 12:20:22 ERROR (MainThread) [hassio.supervisor] Update of fails!
19-04-25 12:20:22 ERROR (MainThread) [asyncio] Task exception was never retrieved
future: <Task finished coro=<HassIO.start() done, defined at /usr/local/lib/python3.7/site-packages/hassio/> exception=SupervisorUpdateError()>

So, it seems that it’s searching for an UPDATE. how can I fix that? Note that I did not set any auto-upgrade function…


SD card full?

Already checked: no.

Seems it can’t find the docker image to load.

Are you running or docker-ce?

1 Like

I’m having the same error.
Ubuntu 18.04.2 LTS
Docker Engine - Community
Version: 18.09.5
API version: 1.39 (minimum version 1.12)
Go version: go1.10.8
Git commit: e8ff056
Built: Thu Apr 11 04:10:53 2019

I used Ouroboros to force hassio supervisor to update but this is not the right way to do this i think. The problem seems fixed now for me.
Keep in mind Ouroboros will try to update all your docker images so i switched it off as soon as possible after the hassio supervisor was starting.