Can't Subscribe to any topics other than $PUB

I’ve just installed HA OS (v5.9) along with the MQTT add-on (amongst others) on a RPi. I’m planning to use another RPi as a sensor and send MQTT messages to HA.

I’ve got HA MQTT accepting publications, as described in the MQTT Discovery page; and the example ‘garden’ sensor successfully appears in HA.

I’ve since ran the mosquitto client externally to the HA RPi (on a Mac) and that also works with the same ‘garden’ publication.

However, I can’t subscribe to any topic other than $SYS. This is both locally on HA and remotely on the Mac.

I initially tried with the mosquitto client and I get a long list for $SYS:

$ mosquitto_sub -h -u remote_pi -P p@ssw0rd -t '$SYS/#' -v
$SYS/broker/version mosquitto version 1.6.3
$SYS/broker/uptime 36872 seconds
$SYS/broker/load/messages/received/1min 4.50
$SYS/broker/load/messages/received/5min 3.40
$SYS/broker/load/messages/received/15min 3.43
$SYS/broker/load/messages/sent/1min 117.35

remote_pi is the user I’ve created in the HA GUI.

However, if I try with homeassistant or #, it just hangs.

mosquitto_sub  -h -u remote_pi -P p@ssw0rd -t '#' -v

Only Ctl-C gets the prompt back.

I can see the login in the mosquitto log on HA. On the Mac I’ve also tried third party MQTT clients (MQTTX and MQTT Explorer) and get the same results.

What am I doing wrong?

if no other topics show up in MQTT Explorer then nothing is being published to MQTT. The SYS topic is the MQTT Broker itself. You can use MQTT Explorer to publish to MQTT and then test from that; but you need to find out why you are not publishing.

Thanks @GlennHA.

That was the nugget I needed for it to click. MQTT subscribers only receive a message when something changes. My (incorrect) assumption was that it would somehow see all the subscribable (is that a word?) topics, which isn’t the case. Every day’s a school day as they say!

Thanks again and have a great Christmas/Holiday.