Can't turn off my Daikin

I can’t turn off my Daikin AC.

In my automation I use:

    - service: climate.turn_off
        entity_id: climate.saraap69238

I tried this, as well:

- service: climate.set_operation_mode
    entity_id: climate.saraap69238
    operation_mode: "Off"

But I get:

2018-05-31 22:00:21 ERROR (MainThread) [homeassistant.core] Error executing service <ServiceCall climate.turn_off: entity_id=[‘climate.saraap69238’]>
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/”, line 1007, in _event_to_service_call
await service_handler.func(service_call)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/climate/”, line 434, in async_on_off_service
await climate.async_turn_off()
File “/usr/lib/python3.5/asyncio/”, line 380, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.5/asyncio/”, line 304, in _wakeup
File “/usr/lib/python3.5/asyncio/”, line 293, in result
raise self._exception
File “/usr/lib/python3.5/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/climate/”, line 764, in turn_off
raise NotImplementedError()

Please, note, in the services page, the second example works like a charm!

Same error for me, any solution yet?

try “off”,
NOT “Off”

Sorry to revive such an old thread, it looks like many people have had the same issue since 2018 and its never been fixed.

I have opened an issue on GitHub for the problem hopefully someone spots the issue and fixes it.

I found I can actually create the scene and while setting to ‘off’ while building, it would turn the AC off, but as soon as I save and go back to scenes and then into the scene, the device doesn’t save the ‘off’ state as per this video

So I know the call works to turn off the AC as it did it, just wont save the scene / command.
I tried manually editing scenes.yaml and trying different states and hvac_modes with “off” and “Off” and all sorts.

Did anyone ever find a fix to this?

It is an issue with the Scenes editor, have a look in scenes.yaml, it stores the right value.

I’ve made a short video…