Can't update connectivity information and random errors in supervisor log

Just recently I started getting this weird supervisor error which come up after HA has been running a few hours.

WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached

Any idea how to check and or repair it?

WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached

21-02-14 12:19:28 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:19:58 INFO (MainThread) [supervisor.host.info] Updating local host information
21-02-14 12:19:58 INFO (MainThread) [supervisor.host.services] Updating service information
21-02-14 12:19:58 INFO (MainThread) [supervisor.host.network] Updating local network information
21-02-14 12:20:08 WARNING (MainThread) [supervisor.host.network] Can't update network information!
21-02-14 12:20:08 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:20:18 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:20:18 INFO (MainThread) [supervisor.host.sound] Updating PulseAudio information
21-02-14 12:20:18 INFO (MainThread) [supervisor.host] Host information reload completed
21-02-14 12:20:48 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:21:28 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:22:08 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:22:48 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:23:28 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:24:08 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 12:38:49 INFO (MainThread) [supervisor.resolution.check] Starting system checks with state CoreState.RUNNING
21-02-14 12:38:49 INFO (MainThread) [supervisor.resolution.check] System checks complete
21-02-14 13:38:24 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 13:38:49 INFO (MainThread) [supervisor.resolution.check] Starting system checks with state CoreState.RUNNING
21-02-14 13:38:49 INFO (MainThread) [supervisor.resolution.check] System checks complete
21-02-14 13:39:51 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
21-02-14 14:00:12 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 14:00:52 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 14:01:32 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 14:02:12 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 14:02:52 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 14:03:32 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 14:26:58 INFO (MainThread) [supervisor.host.info] Updating local host information
21-02-14 14:26:58 INFO (MainThread) [supervisor.host.services] Updating service information
21-02-14 14:26:58 INFO (MainThread) [supervisor.host.network] Updating local network information
21-02-14 14:26:59 INFO (MainThread) [supervisor.host.sound] Updating PulseAudio information
21-02-14 14:26:59 INFO (MainThread) [supervisor.host] Host information reload completed
21-02-14 14:38:49 INFO (MainThread) [supervisor.resolution.check] Starting system checks with state CoreState.RUNNING
21-02-14 14:38:49 INFO (MainThread) [supervisor.resolution.check] System checks complete
21-02-14 14:39:54 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/home-assistant/addons repository
21-02-14 14:39:54 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/hassio-addons/repository repository
21-02-14 14:39:54 WARNING (MainThread) [supervisor.addons.validate] Add-on config 'auto_uart' is deprecated, use 'uart'. Please report this to the maintainer of ESPHome
21-02-14 14:39:54 WARNING (MainThread) [supervisor.addons.validate] Add-on config 'auto_uart' is deprecated, use 'uart'. Please report this to the maintainer of ESPHome
21-02-14 14:39:54 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
21-02-14 14:39:54 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
21-02-14 15:17:59 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:18:39 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:19:19 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:19:59 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:20:39 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:21:19 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:32:29 WARNING (MainThread) [supervisor.host.network] Can't update connectivity information: Error: Timeout was reached
21-02-14 15:38:49 INFO (MainThread) [supervisor.resolution.check] Starting system checks with state CoreState.RUNNING
21-02-14 15:38:49 INFO (MainThread) [supervisor.resolution.check] System checks complete
21-02-14 15:39:51 WARNING (MainThread) [supervisor.addons.addon] Add-on core_zwave_js new schema is not compatible
21-02-14 15:39:51 WARNING (MainThread) [supervisor.misc.tasks] Add-on core_zwave_js will be ignored, schema tests failed
21-02-14 15:39:52 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
21-02-14 15:49:51 INFO (MainThread) [supervisor.misc.tasks] Found new Supervisor version 2021.02.9, updating
21-02-14 15:49:51 INFO (MainThread) [supervisor.supervisor] Fetching AppArmor profile https://version.home-assistant.io/apparmor.txt
21-02-14 15:49:51 INFO (MainThread) [supervisor.host.apparmor] Adding/updating AppArmor profile: hassio-supervisor
21-02-14 15:49:51 INFO (MainThread) [supervisor.host.services] Reloading local service hassos-apparmor.service
21-02-14 15:49:51 INFO (MainThread) [supervisor.supervisor] Update Supervisor to version 2021.02.9
21-02-14 15:49:51 INFO (SyncWorker_7) [supervisor.docker.interface] Downloading docker image homeassistant/amd64-hassio-supervisor with tag 2021.02.9.
3 Likes

I have same problem :frowning:

So quick question do you have the Dyson integration? Or do you have any config items not currently working?

I don’t have Dyson. Everything works.

Having the same flood.
21-02-26 15:46:38 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-02-26 15:47:18 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-02-26 15:47:59 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached

Probably it starts after upgrade 5.9 -> 5.12, but not sure. Only few days was on 5.9 after fresh install, bit NOT noticed these errors on 5.9. Now they appears constantly.

Have no Dyson integration, AFAIK all config items working fine.

Same behaviour here.
No dyson integration either.
System with high CPU usage while messages are being shown in the log.
Log file flooded with the same message every second:

21-03-12 17:20:21 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:21:02 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:21:44 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:22:25 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:23:06 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:23:48 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:24:30 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached
21-03-12 17:25:19 WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached

Same timeout error message. I’ll investigate if this is not related to the Pihole add-on or Ubiquiti router with Internet threat IDS/IPS management systems blocking the connection for some reason.

Quick update, soon I disable Pi-hole add-on I didn’t get any more timeout. Unfortunately, my logs look corrupted so I’ll try to debug it this week when I have free time but it seems to be a good indication so far.

I have the same problem, have to reboot the host once a day, restarting supervisor does not help.

Have the same problem on NUC, every 5 hours after restart.

Same here:

WARNING (MainThread) [supervisor.host.network] Can’t update connectivity information: Error: Timeout was reached.

My log is full of this.

HassOS running as VM in my unraid server.

Same problem here, same messages in logs.
I have my smart home devices on a vlan that’s blocked from the internet and my home assistant VM is connected to two vlans through two virtual NICS. I thought that was causing the problem but it seems others are having issues as well.
I have a separate pihole instance on the server and also the Unifi integration, if that is of any help.
Everything seems to be working fine.

same here…also multiple vlans on NUC