Can't update core - what do I do?

I have a Raspberry Pi 3 with no SD card but an external SSD disk, and it’s running HA OS version 9.3, core 2022.11.1.

I can see that a new core version 2022.12.1 is available, but I can’t update.

  • I have tried to update the core from GUI: After clicking “Update” it just hangs. Nothing more happens.
  • I have tried to issue the command ha core update in the command-line interface; that results in the word “Processing” on the line, and then nothing happens.

After initiating any of these, I am now left with a system that cannot be safely restarted. Whether I issue a “system restart” in GUI or a ha restart in CLI, nothing happens. The log fills with messages that services aren’t available due to a shutdown, but nothing more happens.

In the end I’m left to unplug it. This leaves a dirty bit set in the SDD which I must clear on my laptop before booting again.

So, to sum it up: It seems I’m forever stuck with core 2022.11.1! Can I never update again?

1 Like