Cant update to 2020.12.1

I just tried to update to 2020.12.1 from 2020.12.0
I am running HA in proxmox on a NUC. I have allocated 64 gig of hard drive space to Home Assistant VM, So I can’t imagine it is a disk space issue. When I try to update I get an unknown error and this is the message in the supervisor log…

20-12-17 23:23:52 INFO (MainThread) [supervisor.homeassistant.core] Updating Home Assistant to version 2020.12.1
20-12-17 23:23:52 INFO (SyncWorker_1) [supervisor.docker.interface] Updating image homeassistant/qemux86-64-homeassistant:2020.12.0 to homeassistant/qemux86-64-homeassistant:2020.12.1
20-12-17 23:23:52 INFO (SyncWorker_1) [supervisor.docker.interface] Downloading docker image homeassistant/qemux86-64-homeassistant with tag 2020.12.1.
20-12-17 23:24:02 ERROR (SyncWorker_1) [supervisor.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:2020.12.1 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2020.12.1&fromImage=homeassistant%2Fqemux86-64-homeassistant: Internal Server Error (“Get “”: dial tcp: lookup no such host”).
20-12-17 23:24:02 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

Any thoughts would be great.

Maybe I can be of help. I ran the update while accessing my HA instance over it’s external SSL secured URL. When using the internal URL ( 192.168.x.x:8123 in my case) the update went fine.

I tried a couple more times and one of them it worked. Not sure what happened there.