Card error s.entries is not a function

Hi,

i have this custom card, but also sometimes the same error on other cards.
Error: s.entries is not a function

Why is that?

type: custom:power-distribution-card
title: ''
animation: slide
entities:
  config:
    - entity: sensor.sun_l1_l2_l3_energy_total
      preset: home
      invert_value: true
      name: Haus
    - entity: sensor.solarproduktion_instantaneous_power
      preset: solar
      name: Solar
    - entity: sensor.pylontech_powerdc
      preset: battery
      invert_value: true
      name: Akku
      display_abs: true
      battery_percentage_entity: sensor.pylontech_soc
      secondary_info_entity: sensor.pylontech_soc
      secondary_info_replace_name: true
center:
  type: bars
  content:
    - preset: autarky
      name: Autrakie

2 Likes

Try reporting it to the custom card developer.

Hello,
I am new to Homeassistant, but I have the same error as described above. It is not only with the “power-distribution-card” but with all cards regarding energy or power flow. So it seems to me as it is not a special card issue.
Maybe some of you have experience with such an issue and can help us. The error message is as follows (in German):

"Visueller Editor wird für diese Konfiguration nicht unterstützt:

  • s.entries is not a function
    Du kannst deine Konfiguration weiterhin in YAML bearbeiten."

Thanks in advance!

3 Likes

Is there any solution yet? I have the same issue. I’m very sure that it worked back in the days when I configured the card. But now it does not work anymore because of this error.

Have you reported in the plugin’s repo as it was suggested?
P.S. could be similar