Card-mod not working

Type: custom:mushroom-template-card
primary: Spin
icon: mdi:fan
icon_color: teal
style: mushroom-shape-icon$: |
ha-icon { –icon-animation: spin 1s linear infinite; }

It doesn’t work for me, I’ve tried everything, followed several tutorials, and it just doesn’t run in any way

If you’re on latest versions of ha and mushroom, there’s been some changes. Look in the main mushroom thread near the bottom

Same problem here since upgrade to card-mode 3.4

I cannot get it working, on github several people get it working, but I can’t.

Using the code on a new card:

type: entities
  - entity: sun.sun
  style: |
    ha-card {
      color: red;

nothing turns red.

I do as in the manual:

I installed (rather: updated) card-mod.
I tried with or without

    - url: /local/room-card.js
      type: module

in the configuration.yaml

Config data:

  • Core 2023.11.2
  • Supervisor 2023.12.0
  • Operating System 11.1
  • Frontend 20231030.2
    Using HA via virtual box

What do I do wrong?

Have a look in the main card_mod thread, this one is specific to mushroom cards