Carrier/Bryant Infinitive Integration

Hey guys,

I’m starting a new discussion around the infinitive integration here. The original thread below is starting to have conversations about multiple integrations so I figured I’d move mine to a new thread to keep confusion down.

Updates: I’ve done some digging and realized that I never added humidity control to the pyinfinitive component. I’ll get that added this week hopefully and keep this thread updated with the progress.

Original thread: https://community.home-assistant.io/t/carrier-infinity-integration/17161/118

2 Likes

I did some work on adding the ability to set target humidity in the pyinfinitive python module. Turns out, I don’t think the infinitive API offers that functionality. I’ve put in an gh issue asking if I’m doing something wrong or if it was never implemented. I’ll keep this thread updated.

https://github.com/acd/infinitive/issues/25

1 Like

Well, it was a noble attempt, I was all prepared to get this running over the weekend. However, the way the system control board is situated in the unit, I can’t access the terminal block screws on the ABCD bus. My only option seems to be cutting the thermostat wire that runs between the unit and the existing thermostat, and I have a bit of trepidation about cutting working wires and splicing in a new line.

@racerx2oo3 - Completely understand the hesitation but as long as you connect the wires back correctly with wire nuts, it will be fine. One of my A/C’s had already been spliced so I tapped into that and no issues.

Hey @mww012 - I’ve been brushing up on my Python skills. What do you see as the next step towards getting this pulled into HA?

I’m having stability issues after upgrading HA to 0.95. Anyone else? I have to continuously reboot the PI I have connected to my Carrier.

@scott.parmenter so far I’ve been stable. I’m running 0.95.4 and haven’t had any issues.

@Tj_Davis I’ve let this project lag a bit. Just been busier lately than I’d like to be. To get this submitted we’ll need to run tox scripts against it and fix whatever doesn’t pass. I’d like to write the ability to configure the integration from Lovelace and not require yaml since the yaml config itself is so basic. I was re-reading the pull request notes on the HA developers page and saw the blogpost below. We may want to get things in order but not actually create a pull request until after the 0.96 changes. Any thoughts?

Thanks @mww012. I actually think it’s an issue with the PI I have connected to the Carrier. I’m not a PI expert whatsoever, but I’m wondering if I should set up the PI to reboot once a day. Any thoughts?

@scott.parmenter The place I’d start is looking through /var/log/syslog and see if anything looks out of the ordinary. I’d be happy take a look if you want to attach the log file.

Hey guys. Just wanted to give everybody a heads up. I started working on the 0.96 changes for the infinitive component. Sorry it’s a little later than I wanted but hopefully I’ll be able to turn it around quickly.

Awesome, thanks! If there is anything I can do to help, let me know.

Will do. I started working on it yesterday. I made a good bit of progress but still got a few kinks to work out. I’ll put some more time into it this evening and let you know how it goes. Right now something I’m doing is putting the HA’s entity helper into and infinite recursion loop. Hopefully that’ll be my last major hurdle.

@Tj_Davis and others with multiple Bryant systems, before I go down a change the settings rabbit hole, does anyone know if it is possible to connect two rs-485s (one for each of two HVAC systems) to one raspberry pi (I have a 3 B+)? Or, does each system and rs-485 need its own Pi? Thanks!

That’s not something I’ve had to tackle. I expect you could run two different rs-485 adapters on one RPi. You’d just run two instances of Infinitive (probably using screen). Have one using /dev/ and have it listening on one port (default 8080), the second using /dev/ and listening on another port (e.g. 80801). In the HA component you’ll just make two entries. Something like this…

climate:
  - platform: infinitive
    host: 'rpi ip address'
    port: 8080
  - platform: infinitive
    host: 'rpi ip address'
    port: 8081

If you decide to give it a shot let us know how it goes. If HA gives you any issues having two references to the same platform let me know and we can look at what is needed to make it work.

Just FYI for everybody…

I’ve got the the Infinitive component running on 0.96. I just got things settled so I’m going to do a few preliminary tests and then I’ll get the branch pushed up to my github repo. As soon as that happens I’ll let you guys know and throw in some quick instructions if you want to give it a test drive. After we think the kinks have been worked out I’ll merge it into the master branch and well hopefully be good to go for the future.

1 Like

@jmckinleyii I was tempted to try it but, as @mww012 said, it should work with multiple instances of infinitive, just make sure you configure the correct TTY for each one. Definitely let us know how it goes if you try it.

I’m game to try, but I’m having the same issue/error as strikeir13 described in post #76 in the original thread (running hassio 0.95.4 in a virtualbox VM). I tried the solution you described in post #88, but the HA UI won’t load unless I comment out the climate config.

@jmckinleyii - I’m not seeing the post numbers so I’m not sure which issue it was. Are you able to ssh the box and send a copy of home_assistant.log from a failed load?

I’m traveling and for some reason I’m not getting in by SSH remotely to get the log but this is the message HA gave:

“You are using a custom integration for infinitive which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.”

I can access Infinitive and manipulate the system using a browser, so I know it’s working. I just can’t get the HA integration to work.

I’ve seen this when they last changed the climate component. The root cause was that the support_flags that the Infinitive component uses has something that is no longer in the list of things that can be supported. What’s a bit odd is that there’s nothing in 0.95.4 that isn’t supported…wait…FML. I think I may have realized what you need to do. Try this…

  1. Go to your custom_components directory via the cli
  2. Run “git checkout ha_0.92”
  3. Restart HA

See if that gets it for you. If that’s the problem then it’s my mistake. I need to merge the ha_0.92 branch into the master. Let me know how it goes.