Cast on 0.109.6

Hi guys!

Since upgrading to 0.109.6, home assistant cast seems to “time out”

I havent quite worked out exactly what the issue is yet, but the timing suggests its related to the HA update.

After about an hour, my Google Hub reverts back to showing photos, rather than HA via cast. Anyone else experiencing this ?


Update – it just happened, and this time i noticed that the Google Home app said that it was still casting, so it looks like its some sort of google timeout itself.

Yes I’m seeing the same issue, this worked fine early last week but now it reverts back to the ambient screen after about 30 minutes. Possibly caused by the Hub update that came out last week.

It definitely looks that way. Im sure the Google Home App used to have an option to disable ambient mode, but its gone.

Looks like my Google Hub just became a fancy expensive clock again :frowning:

I’ve set an automation to cast againe very 10 minutes, works okay.

Oh – thats a good solution!

Can you share your automation here please?

I found another workaround, as it’s still casting you can swipe down, select media and continue casting.

I tried setting this is up in Node-Red, but it didnt seem to fix the problem annoyingly.

Having said that, ive never got cast to work from HA itself, only using

that didnt seem to work for me – i can see its there, but it doesnt let me b ring it back up again.
I dont know if the Australian version i have is different (ie Google Home Hub, not Google Nest Hub)

so this is what I do:

  • swipe down on the screen
  • choose media
  • hit the cast icon with the name of my Home hub
  • I get another screen that says now playing so i hit the top right to continue casting. It’s not very user friendly :slight_smile:

I “broke” it by sending acast command to a non existant view, so i could confirm the service was hitting the hub, but it still went into ambient mode.

@wilhelmstroker your method works, but its VERY clunky. The Wife Approval Factor for HA is out the window with the hub not workin g.

Yup it’s very clunky and annoying. Not sure what to do though, it looks to be a google issue. If only google allowed us to disable ambient mode…

Absolutely, this is the flow I use for this:

What are the contents of that exec call ?
Im just using a service call for cast, which doesnt seem to be working.

I’m actually using Catt to stream.

You should be able to use a node like this one instead of that exec call.

Oh for enough.
Yeah – thats what im using, except that it doesnt work :frowning:

It doesnt bring it out of ambient mode.

I just realised that node read was out of date, and i only had view_path, not dashboard_path. So I have updated that and will report back

I HIGLY recommend giving Catt (Cast all the things) a try.

My camera is way more fluent with it ( Using an Iframe pointing to MotionEye) and I can even click on elements to bring up the more info panel.

Catt seems a far more likely candidate.

Ive managed to get it to work – sort of. The Google Hub displays a login window though.

ah cool, thanks for that! this might just be the reason for me to finally implement node red :smiley:

Yeah, you need to use the trusted networks to log in.