Casting dashboard gets stuck on "Connected"

I’m trying to cast a dashboard view to a Google Nest Hub. When I start casting, the Hub immediately shows some HA/Nabu Casa graphics, followed by “Not connected”. After a few seconds it switches to “Connected” and then gets stuck there.

If I then recast the dashboard again after the Hub shows “Connected”, it shows up and works as expected.

I’ve tried using both the Google Cast service and play media service, with the same result. Casting anything else, like a camera stream works as it should, so the problem seems limited to when trying to cast dashboard views only.

Does anyone have any suggestions for what could be the issue here?

2 Likes

Can you show us the yaml Code

  - service: cast.show_lovelace_view
    data:
      entity_id: media_player.livingdisplay
      view_path: heater

mine look like this.

I’ve tried a few different ways (even selecting the dashboard in the GUI using the media player card gets the same result), but here’s my current config:

service: cast.show_lovelace_view
data:
  entity_id: media_player.nesthub6a24
  dashboard_path: dashboard-projections
  view_path: kitchen-sonos

I can add that I did eventually find a (messy) workaround. It doesn’t solve the inherent issue, but at least my specific automation works.

I noticed that the Google Hub media player doesn’t change state to playing until after it gets stuck at “Connected”, so I’ve added a wait step for when the media player changes state and then cast the dashboard again.

1 Like

I have the same issue. Do you run the 2024.3 version?

Yeah, I’m running 2024.3. Sadly, I can’t confirm which versions that might be affected by this, other than the latest one.

I have played around with Google Cast previously a long time ago, but I can’t remember seeing this problem until now when I tried to build an actual automation. Until now, I’ve only had to cast camera streams, which work as expected.

I followed you idea and casting the dashboard twice with a bit of delay and for now it is working fine for me

Same for me, even with a blueprint that recast

Ich have the same problem since 2024.3. Do someone know how to open a ticket for this?

i choosed 5 seconds delay and that really worked. how did you do it?

I’m currently on mobile so I don’t have the exact configuration in front of me, but essentially instead of a timer, I’ve added a “wait for trigger” step that waits for when the media device changes state to “playing”.

It’s not the most elegant solution, but it should at least be quicker than a simple delay.

2 Likes

I can confirm that Daniel’s workaround works for me.
I’m using Node-Red and I have added a wait until my mediaplayer is ‘playing’, then cast the dashboard again.
Hopefully next month’s update fixes this issue.

I am also facing this issue, noticed it happening ever since the latest update (2024.3).

Thank you very much for the temporary workaround - works great!

I have this same issue, and it looks like a fix is scheduled to be released in 2024.3.2

3 Likes

Can you share how you did it via Node-Red as I am currently learning how to use it?

Node-Red is pretty awesome. I added a ‘Wait Until’ node after the Cast to Dashboard node.
Screenshot_20240322_152137


Hopefully the screenshots will give you some idea on what to do.

1 Like

I just installed the 2024.3.2 and the issue seems fixed :slight_smile:

1 Like

I have the same issue running 2024.5