Catastrophic failure, MQTT stopped working even after full restore and host reboot, completely stuck

Background: HA 2021.6.2, Rpi4. Had delay in zigbee/mqtt, some recommended installing Mosquitto 5.1. Couldn’t install that, reinstalled latest 6.0.1, now no mqtt devices work.

Tried: complete full restore of previous config, full host reboot, still not working. Zigbee2mqtt detects devices and actions such as button presses correctly. After the full restore, these also stopped working: history, recorder, logbook, automation. I can’t update nor restore (“system is starting” for 20 minutes now).

Here’s Supervisor log, Core log, Mosquitto log (nothing wrong), HA log.

I can’t restore or create snapshot, because

21-06-08 10:09:29 INFO (MainThread) [] 'SnapshotManager.do_snapshot_partial' blocked from execution, system is not running - CoreState.FREEZE

Please help, my home is almost useless without this. I’m completely stuck. Can’t update, can’t restore, can’t do anything. Thanks.

Apparently it took more than half an hour without any notice or notification to restore the snapshot. It booted while not being fully ready, spitted out a bunch of error messages about mqtt and THEN proceeded to - - apparently - continue the restore in the background. MariaDB database got corrupted, so I had to uninstall/reinstall.

I understand this is complicated stuff but the restore process needs some more UX care.