CC2531 Hardware problem? Cannot open / LED goes off


my zigbee network (40 devices) was working perfekt for the last 6 month. Today nothing is working - i just get: Error while opening serialport ‘Error: Error: No such device or address, cannot open /dev/ttyACM0’

It´s a CC2531 stick i bought already flashed … and it always worked.

When i plug the stick in i get:

  - /dev/ttyACM1
  - /dev/serial/by-id/usb-0658_0200-if00
  - /dev/ttyACM0
  - >-
  - /dev/ttyAMA0

I tried configuring the serial port with the serial id as well as /dev/ttyACM0
After some seconds (sometimes 1 - sometimes 10) the LED turns off and the device seems to be gone

  - /dev/ttyACM1
  - /dev/serial/by-id/usb-0658_0200-if00
  - /dev/ttyAMA0

Is my stick broken? Please help - my girl is trying to kill me already.
Should i get a new one? Should i change to another Zigbee Stick?

Is there anything i can do now?


Did you try to press the button already ?

Yes - i pressed the button & did several reboots

You could try to reflash it.

I don´t have a debugger :frowning:

But after some hours of reading i ordered a conbee II (only stick with same-day delivery) … my network is getting bigger soon and i guess the cc2531 will be too slow soon. Resetting 40 devices will be lot of fun tonight :frowning:

Not sure if i should try deCONZ or continue with Zigbee2mqtt with this stick?

Can you post error after using the full serial name?

I got the same error: No such device or address, cannot open

Meanwhile i got my Conbee 2 - plugged it in and it worked … re-pairing was not as painful as i thought - all of my switches (and automations) worked after a reset.

I guess the CC2531 was broken.