CC2531 USB Dongle with Virtual Box

Hi Guys, I’m struggling with setting up my cc2531 to work within Virtual Box.

I’m using Windows 10 Pro and can’t find a driver but didn’t think that was an issue?

I’ve attached snippets of my settings, I know the Serial port needs to change but I can’t work out what I need to fill in, please help!


Is this of any use??

1 Like

Thank you, that may just help actually!

It seems that not having drivers for the cc2531 in Win10 is in fact a problem, do you have them by chance or know where I can get them? I’ve tried 2 sources so far with zipped files (swrc088c and vcp)

It should mount itself as a generic com port automatically, I did not require any special drivers for it.

PS, what you tried to do in Vbox should also work, but you either use usb OR ser, not both.
However, i lack the linux knowledge to determine on where to find it linux…
Unfortunately, in HyperV I can’t pass these from W10 to my virtual machine, that is why i do it over tcp :thinking:

lsusb will show you what USB devices are connected to the VM.
dmesg | grep 'tty' will show you what port the device is connected to.



@code-in-progress What about mounted com ports?
(in case he doesn’t use the USB pass-through drivers) ?

Those should show up using the dmesg | grep tty as they should be exposed to the VM as general USB serial ports.

If they don’t show up that way, then the other thing would be to install setserial and use that to query for serial ports exposed to the VM: sudo setserial -g /dev/ttyS[0123] (This command normally requires sudo privileges to run).

Is it possible for you to upload that exact file for me because I can’t find it. I did read that after the Win0 creators update peoples cc253x devices stopped detecting?

Ok cool, it’s basically if I add as a USB as seen in my second pic… then when I try integrate Zigbee, no device is automatically found but when I user seiral port then it at least picks up the device… but I have Port Mode set to “Disconnected”… which of course won’t work but it does show in the Zigbee integration

This is what showed up:

Hmm…I don’t think I can isolate the generic usb2serial driver…
And it should not be an issue; my w10 is fully up-to-date:

My 2 cents:

  • When you enable pass-through for USB, it will not be available under W10, as it has been ‘moved’ to virtual box ( at least that is how it works with VMWare)

I also cant remember if I did install a seperate driver for it… maybe it came with TI’s smartrf flash programmer ?
Is this of any help?

One step closer… I think, that driver worked!

@HellfireZA more info om the topic
HASSOS in Hyper-V - Is it possible to install USB Rediector or something similar for USB support?

A little late but I was wondering what to do after you install that specific driver. It doesn’t assign a COM port so what do we do after we install that driver.

It should recognize it as a com driver…
After downloading, unzip it, and then right click the driver and select ‘install driver’

Or maybe it is this one?

Ok so I got that driver installed but it says that the device could not start. I did a bit of googling and I found that it’s because these are drivers for 32-bit machines. What should I do next?

hmmm…try this one…/
Looks like it has 64bit drivers…

So this one works but it doesn’t assign a COM port… Is there something I’m missing?

Most common reason the CC2531 does not assign a COM port : it is not flashed with the Zigbee2MQTT firmware.

That’s what I thought so I just bought a debugger. It is coming tomorrow. Thanks for your help!

Ah…yes, you need the cc-debugger in order to flash the CC2531 :smiley:
I assumed that was done long time ago…

and especially for the CC2531