CC2652R randomly stops running after a day

Most recently, My zigbee coordinator (CC2652R firmware ver.20220219) randomly stops running. It seems to run continuously for 1-2 day max. I have this coordinator for 1.2 years and it never stops running all of a sudden.

It started when I have updated to HA core 11.5 and update zigbee2mqtt add to 1.28.4-1. I have checked the Ha logs and there is no pertinent errors. Nothing in the zigbee2mqtt logs either. How to troubleshoot this further.

I have tried changing usb port (no go) and now have added a usb extension cord. Will see if this works after a day or so.

I stopped again. I checked the zigbee2mqtt log and this was the last it output.

Zigbee2MQTT:error 2022-12-10 12:44:18: Publish 'set' 'color_temp' to 'w_4' failed: 'Error: Command 0xf0d1b800001669e7/1 lightingColorCtrl.moveToColorTemp({"colortemp":370,"transtime":10}, {"sendWhen":"immediate","timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":false,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Timeout - 28870 - 1 - 111 - 768 - 11 after 10000ms)'
Error: Write 0xec1bbdfffe48d527/1 genLevelCtrl({"onLevel":255}, {"sendWhen":"immediate","timeout":10000,"disableResponse":false,"disableRecovery":false,"disableDefaultResponse":true,"direction":0,"srcEndpoint":null,"reservedBits":0,"manufacturerCode":null,"transactionSequenceNumber":null,"writeUndiv":false}) failed (Timeout - 28311 - 1 - 163 - 8 - 4 after 10000ms)
    at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/src/utils/waitress.ts:64:35)
    at listOnTimeout (node:internal/timers:559:17)
    at processTimers (node:internal/timers:502:7)

Anyone knows what times means and how to go about this??


You ever figure out what was going on with this? I’ve been dealing with silimar symptoms with the exact same error. I’ve tried updating the stick, resetting the NVRAM, turning off modemmanager and hciuart services, and a bunch of other stuff. This has been an issue for me since before your post. My instance of z2m is installed on a pi and not in docker.


I’ve never figured out why it was happening. As a bandage fix, I’ve enabled watchdog.

Thats really unfortunate. At this point, I dont know what to do. I guess I could get a new stick and completely rebuild the network…