Cec-client can't find any devices other than itself

I followed the instructions here to install the cec-client on my Raspberry PI running Raspbian. I configured the symlink, and added the HASS user account to the video group. However, my cec-client doesn’t seem to be able to find any devices:

pi@raspberrypi:~ $ echo scan | cec-client -s -d 1
opening a connection to the CEC adapter...
requesting CEC bus information ...
CEC bus information
device #1: Recorder 1
active source: no
vendor:        Pulse Eight
osd string:    CECTester
CEC version:   1.4
power status:  on
language:      eng

currently active source: unknown (-1)

It just seems to find itself, and not the TV or the Chromecast that is plugged into a different HDMI port than the RaspPI. The TV supports CEC, as the Chromecast can turn on and tune the TV to the right HDMI input. I tried swapping HDMI ports so that the RaspPI used the port that worked for the Chromecast, but got the same results as above.
There doesn’t seem to be anything wrong with the HDMI cable, as the Raspbian GUI came up on the TV when it was plugged in and the TV was switched to that port.

Any ideas on what else to try or look into? Maybe something is wrong with my cec-client since it can’t see anything other than itself?

Are you sure the HDMI cable supports CEC? I could be wrong, but it seems far from all HDMI cables do.

I actually thought of that this weekend (although I was pretty doubtful), so today I grabbed a new HDMI cable from work, and guess what…it actually works now!
I had no clue that some HDMI cables don’t support CEC. It seems like it is nothing more than a signal to me, but I guess I am wrong about that.
Thanks for the help!