Change entity name again?

I already tried to change the entity name for a TRADFRI bulb. Following the instruction on


showed me the following error:
save failed: Invalid entity ID
I liked to change the entity name to: “light.OG_WZ_Lampe_Decke1”. Because of the error above, this seems to be a invalid name. So I tried to “light.OG_WZ_Lampe” first. My plan was to enlarge the name piece by piece until it fails again.
“light.OG_WZ_Lampe” worked, but now the little gear in the top right corner of the is no longer there.

How do I change the entity name a second time?

Already found this post:


But searching the configuration directoy gave me only two files with the content “light.OG_WZ_Lampe”:

  • home-assistant.log
  • home-assistant_v2.db

I think it makes no sense to edit these files…

there should be a cog wheel when you click on entity

1 Like

thanks for the quick replay. Unfortunally I posted a pre-version on the text first… now you find above the full question…

You need to edit the entity registry in the .storage directory.

The reason it broke is because you’re trying to use capital letters in the entity_id and unfortunately there is no error check. Use only lowercase letters.

1 Like

Thank you for this useful information. This solved my problem.

1 Like