Change password in Configuration.yaml

I was concerned about my system being hacked so I changed the password in my configuration.yaml file and rebooted home assistant. I ended up getting all sorts of HTTP errors, I didn’t think to copy any of them, but should this be expected by just changing the password?

I changed it back to the original password and it booted fine. Shouldn’t I be able to change the password? Has my system been hacked to the point that changing my password blows it up?

Thanks for any help provided

when changing your password did you possibly miss out the space after the : ?

1 Like

Run hass --script check_config before you restart the program.

SparkyDave, Thanks I believe that is what happened. I went back to the old password and seemed to remember there wasn’t any space. When I tried it again I made sure there was a space and didn’t have any issues.

Tekki, I normally use the config check and it has saved my bacon a few times. I just figured what can go wrong with changing the password… I guess I found out…

Solved, I missed the space after the ?, formatting in yaml is critical as I am sure everyone has found out at least once while changing config files.