Change WLED segment master behavior

Now that WLED 0.11.0 allows you to save segment information in presets I want to propose a change to the WLED integration to help with controlling all segments whether there is current 1 or multiple active.

At the moment if you only have 1 segment then no master segment shows up in HA and the light entity is effectively the master. Turning this on or off turns the whole device on or off. When you switch to a preset that utilizes multiple segments the you gain a master light entity and the additional segments. The additional master segment now controls the device instead of the original entity.

I am proposing to always have the master light entity available and an option to either hide or show the first segment entity when there is only 1 segment and show all segments when there are more than 1. This would make the master light entity always available to automations regardless of segment count. This way, it is easier to turn on or off the entire device regardless of active segment count.

Hello andyshinn,

for me it would be greate to have a “master” or lets call it “main” switch per default. If I change between setting with only one segment or multiple segments I have to alter the automations everytime.
So it would be greate.


Guys, I’m also seconding this. I have my Dashboard configured to control the master. Now when a preset runs with only one segment, I loose the Entity in my UI. Do you guys maybe have a workaround?
Display Master controls and if they are unavailable use segment control? How would this be done?

This is also really bad for my automations…

I’ve been using nightlight as a workaround. In WLED you can set nightlight to a low value (like 1 minute) and then use this as the switch to turn on/off. The downside is that you have to wait 1 minute for the light to turn off which may not always be desirable.

Thanks for the Inspiration!

i am now using MQTT to toggle the WLEDs which works perfectly.
Also I’ve embedded the full controls via a website card which is pretty cool.

I would very much like this behavior as well. I use presets with only one segment sometimes and that causes issues. The latest update seemed to make reference to master remaining but it doesn’t seem to be the case.

It should be in 2021.7.X. But you need to enable it. Can you check:

1 Like

I didn’t see that…looked everywhere but…yep that works. Wow, that was record time for an answer. Thanks so much!

I marked my last reply as the solution since this is implemented and works the way I would expect. I would have liked to have the master entity change colors of all segments at once. But just being able to turn on/off the entire device regardless of segments on a single entity is so much easier for automations. Thanks @frenck!

Can we close this feature request?
I found it (2.5 years later :)), voted for it, then found the solution and realised it should no longer be a request.