Changed hostname now SAMBA won't correctly work on Win10


#1

Bottom line is I wan to run two HASSIO Pi’s. One for the everyday use, which is working fine, and a second one that I can use for testing because I constantly am locking HASSIO up trying to figure out how to do things. On a fresh install I first went in and change the hostname to HASSTEST and then installed the Samba share. In Windows I can see my normal HASSIO folder from the first Pi and access it with no issues. I can also see the second folder HASSTEST but upon trying to access it I get an error stating it can’t find it. Anyone else have two services running?

Thanks,
Tom


#2

Can you try navigating directly?

//ipofhasstestpi/sharedirectory

so

//192.168.1.2/config


#3

Yes. As far as the browser related stuff goes that all works fine. Being new to HA the only way I know how to edit the *.yaml files though is through the Windows file management system so that I can use something like Visual Studio as an editor.


#4

I would like to figure this out just in case it causes some other issues down the road. That being said I can, and will for now, use the HASS configuator option.


#5

You can use an ip in windows explorer to navigate to a samba share.


#6

Go to start menu and search for credential manager. Open it and choose Windows credentials. Remove anything related to your samba shares. Either it is an IP or a hostname.

Now open a command line (search for it at the start menu again) and type this:

ipconfig /flushdns

That should do the trick. Even though it is not necessary, I would recommend restarting windows after that process.


#7

Thanks for the tip but this didn’t do anything. Remember the sequence was fresh install, changed hostname and then added Samba which Windows could never find the name of to open even though the name of the network does show up in the file manager.


#8

Instead of Samba I use Notepad++ and the nppftp plugin. All free and no need for any addon. I dont use Hassio but I think it works the same


#9

Thank you to everyone who responded. I appreciate it greatly. Ironically I just updated both servers to the new release and the one that I was having issues with now is visible in Windows file manager via SAMBA under the new hostname of HASSTEST. Glancing over the update notes I think this was sort of a fluke, perhaps the update reset or triggered something to make it all work. None the less yes you can have at least 2 HASSIO servers running on separate Pi’s at the same time. Now I can test out new scripts on one and if it locks up then it’s no big deal since I can just revert back to a known working setup without taking my house down. Really happy. Very different than OpenHAB2.