Changed router, can't get HA to work again

I had an issue with my ATT BGW210 router and ATT sent me another one, exact same model. Installation was very smooth but the only thing that did not work was HA. I am on Windows 10 and run HA from spare laptop using VM VirtualBox. I rebooted all equipment and no luck. I had not sent the old router back so I hooked it back up and voila !, HA worked again, so it is something in the settings of the new router that is giving me a problem. I did add the port forwarding that I had in my old router of 8123 using TCP/UDP but still no luck. The only setting that I noticed different was that my old router had IP passthrough enabled and the new one does not. Not sure if I did that HA or not, but I was not able to enable it on the new router. It would allow me to add a MAC address, but it did not show an IP address like my old router did. My HA has been stable for almost 2 years and I am pulling my hair out trying to troubleshoot. Any help appreciated, not sure where to start.

Update: rebooted 1 more after i did the IP passthrough using the home assistant MAC entry and it worked this time. Life is good again :slight_smile: