Changing configuration value for Aeotec ZW089-A getting error

So i’m trying to change a parameter on my AEOTEC Recessed Door Sensor and it seemed pretty straight forward. I want to change configuration option 121 to a value of 16.

So after using the openzwave library in python to connect i issue the following command:


And i get the appropriate response which is:

2016-09-11 16:38:15.294 Info, Node003, Received Configuration report: Parameter=121, Value=256

So i then issue the following command to change parameter 121 to 16 and here’s what happens:

node3.set_config_param(121, 16)
2016-09-11 16:39:56.086 Warning, Invalid Index Set on ValueList
Segmentation fault

What am i doing wrong here?

Have you tried using OZWCP?

I can’t comment about python, but is there a get function for reading existing config param? Just to see if that call returns alright

Wow that actually worked! The key to using OZWCP was pressing the “Action” button on the sensor so i could actually see the config options. That’s what was causing me to go from OZWCP to straight command line but this is way better now that i know what i was doing wrong.

Thanks Tomek!

@kirby - can you shed any light on this? I just got my ZW089-A in tonight - and this is EXACTLY the issue I’m having. I’ve tried keeping the device awake while setting the setting from basic set to binary report and all I get in the console is the “post: key=14-CONFIGURATION-config-list-1-121 data=Sensor Binary Report size=20
2017-03-22 19:54:17.410 Warning, Invalid Index Set on ValueList.” warning.

Any help would be much appreciated!