Changing default conversation agent in automation and back

I am struggling with an automation. When triggered I want to be asked if I would like to do something, respond, and the execute an action. The issue here is that i am using the extended openai conversation agent as default which can not handle conversation wait triggers. So somehow I have to change to the home assistant conversation agent to get my response and then change back. Is there a way to do that?

Try fallback conversation. Mine is set up to try locally first, then Open AI if local cannot handle it.
m50/ha-fallback-conversation: HomeAssistant Assist Fallback Conversation Agent (

Thanks, I will check that out. For now I have solved it setting the default agent as the home assistant agent and then setting the openai for other cases where I can define the agent id