Changing IP-addresses in HA of Shelly Gen 2 devices - how to do that?

Hi,
we are in the process of migrating all our Shelly and ESPhome devices to a separate WiFi-network with a separate IP-range. Routing between the old network (192.168.16.0/24) where HA is located and the new network (192.168.18.0/24) works.
For Gen 1 Shelly devices there are no issues, the use the CoIoT configuration to point to HA and all is fine after moving them to the new network. The kept their HA ID so all automations etc are working.

However, our Gen 2 Shelly devices are added by IP address from HA so I don’t understand how I will be able to move them over and keep everything working. I can’t find a setting to simply change the IP in HA.

Any ideas?

no idea, but requesting help too.
I just set them up via WiFi (verifying everything looking good)
afterwards connected them via Ethernet (5 pieces all together)
and gave them “static” ip addresses within Fritz box.

Afterwards I stopped hass, modified the file .storage/core.config_entries and replaced all ips, started hass

4 of them are working; one of them changes back to the old ip address, which is not reachable anymore.

I deleted the whole entity within the file, deleted from UI, modified the file during startup. Only thing left in my mind is replacing this one with a fresh bought one. It seems there is more than 1 truth within hass…

Sorry to hear about your problems.
After posting here I simply changed the WiFi network of the Gen 2 Shelly devices. With mDNS relay between the networks (they are on separate VLANs), Home Assistant magically picked up the change of IP-address on the devices and simply re-added them to HA.