Changing the channel of a ConBee II Zigbee controller

I have been having all sorts of issues with Zigbee devices dropping off and rejoining the network that can be attributed to the interference the network is getting from in range WiFi networks.
I thought I’d go ahead and make a simple channel change to my ConBee II device to see if it fixes the problem. That’s were my problems started :slight_smile:

It turns out there is no simple way of changing the Zigbee channel in the ZHA integration for Home Assistant. It also turns out that the ConBee II is factory set to channel 15 which clashes with an over used used WiFi channel (non-scientific statement, based on asking friends and family to check their routers for me and to do wifi scans in their homes).

The ZHA integration has a section on channel use:

      channel: 15             # What channel the radio should try to use.
      channels: [15, 20, 25]  # Channel mask

I followed this example but had no luck with the ConBee II device, so assume it only applies to one or two of the supported USB devices.

I googled and found lots of references to other people trying to change the channel too, but following what they suggested was unsuccessful.

Finally, in a fit of frustration, I contacted DeConz support and found them to be incredibly helpful. They answered my post within 10mins and I had a fix within 30mins.

For those of you who are also struggling to change channel. Here is what I did and I hope it helps.

I run HA on a Synology NAS in a docker container. Using this to do anything clever with the ConBee II device is not advised as the marthoc/deconz docker container seems flakey at best when accessing the USB device,
I didn’t want to install any 3rd party software directly on to the NAS, so I decided to plug the ConBee II into a Windows machine and configure it directly using the DeConz software.

The advice from DeConz was as follows:

  • Open the DeConz software and connect to the ConBee II
  • Open the Network Settings
    – Set the channel you want
    – Click Save
    – Click Done
  • Leave the Zigbee network by clicking the Leave button
  • Exit the application
  • To check the setting has been changed:
  • Unplug and plug back in the COnBee II
  • Restart DeConz and enter the Network Settings dialog
    – Click Read
    – Check channel is selected
  • Exit the software
  • Unplug your ConBee II from the Windows machine and plug it back into your NAS
  • Restart Home Assistant

HA will now use the new channel, but you will need to wait for all your Zigbee devices to time out on the old channel and scan for the new channel. I found some devices switched to the new channel in 10-15mins, but some took over 4 hours to come back online in HA. Be patient. They all came back online for me in the end :slight_smile:

For reference:

  • My ConBEE II is running firmware: deCONZ_ConBeeII_0x266f0700.bin.GCF
  • I used the following DeConz software: deCONZ_Setup_Win32_V2_12_03
    Both can be found from this server: DeConz

You can also do it in HA with the Deconz integration:

Deconz (from the side menu) > phoscon > log into your stick > gateway (via the 3-lines menu in the top-left of the window) and then advanced in the bottom-right corner.

You can change the Zigbee channel on that advanced screen (3rd option of the 4 presented).

How that integration will sit with ZHA I have no idea, as I run mine directly with Zigbee (without any issues).

I’m running HA in a docker container, so installing the DeConz integration is not an option for me.

One other thing to mention: if you have any Aqara devices then do not use Zigbee Channel 26 as I found out the hard way that only the Window sensor in my configuration was able to support that channel. All my other Aqara devices (Motion Sensors, Buttons & LUMI Weathers) did not work on that channel.

For anyone else following tthis, and finding that the new channel wasn’t saved… I found that after changing the channel, I had to click Leave, then also click Join, before closing the application.

A massive thanks to @wizbang for writing this up - helped me a lot!

1 Like

same Problem here,
the Stick was not saving the Channel.
going to deCONZ_Setup_Win32_V2_13_04.exe
works great