Check Home Assistant configuration

Greetings friends, I am using the “Check Home Assistant configuration” compatibility tool to test the configuration of my system with the new versions of
This tool has reported me in a couple of times that I have used this message:

starting version 3.2.2
[INFO] Start install HomeAssistant 0.72.0
You are using pip version 9.0.1, however version 10.0.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
[Info] Install done, check config now
[Info] Finish :slight_smile:

Please could you tell me how to do the “pip” update, I tried using putty with the “root” user and the commands accessible without success.

Thanks for the help

you could try putting this command in a shell_command and then run this shell command from within Hassio

I’ve tried it in various ways using putty and “root” user without success.

Try this:

  pipupdate: pip install --upgrade pip

Then run the shell command from the services tab (Bottom Left in the UI) that looks like a remote.

I learned that some commands do not work using SSH, but work if started from within

Thank you very much for your help @AlmostSerious, I put the two lines at the end of my file “/config/automations.yaml”, then when reviewing the configuration I get this error message:
Configuration invalid
Invalid config for [automation]: [service] is an invalid option for [automation]. Check: automation-> service. (See /config/configuration.yaml, line 20). Please check the docs at

Where is my mistake?

It’s not an automation it’s a shell_command therefore it goes in either your shell_commands.yaml or in the configuration.yaml.

Thanks @ keithh666, add the “Shell_command” to my configuration.yaml file, restart the system, then I went to the “remote control” of services use the new command with “Call service” and it gives me in the system log this error:
Tue Jun 26 2018 16:47:16 GMT-0600 (hora estándar central)
Error running command: pip install --upgrade pip, return code: 127
NoneType: None

Any suggestions?

Well I have tried investigating how to do the update and I can not do it!

try pip3 instead of pip

So far so good, there are no errors in sight … :slight_smile:
Can you tell me if there is any way to see if this service was updated?

Good afternoon !

You may be able to check using the supervisor account via ssh, but I wouldn’t bother. If you do it will be something like pip3 -V or -v or --v or --V I can’t remember :stuck_out_tongue:

1 Like