Chromecast not visible after update 0.57.2

Somehow after the update to 0.57.2 my Chromecasts are not visible anymore.
For the update it was working, got 2 Chromecast Audio and 1 Chromecast TV.

Any thoughts what could be wrong?

The following warning can I find in the log:

2017-11-08 19:26:38 WARNING (MainThread) [homeassistant.components.media_player] Setup of platform cast is taking over 10 seconds.

They where visible in states as:

  • media_player.woonkamer
  • media_player.tuin
  • media_player.overal
  • media_player.slaapkamer-tv

My cast devices disappeared recently as well, but prior to the 0.57.2 update. See my post here: Trouble with Chromecast Audio different firmware versions

I believe it is due to a cast firmware update. What firmware are your cast devices running?

1 Like

I’m running HA 0.57.2 (RPi2, normal installation, Python 3.4.2, no docker etc.) with two Chromecast Audio and one Chromecast Video without any problems! So it’s not a general problem…


What is the firmware of your Chromecast Audios?


Good to hear. According the different topics it looks like it and also what you also already mentioned nothing to do with the Home Assistant update.But I guess it’s related to the update from Google itself.

Right now: 1.28.100555

Okay, @johnnyletrois had the issue with the same firmware… this bug keeps getting weirder.

Hi me too it’s very strange before last HA update audio chromecast was working very well but now with the last update no cast si present!
HA. I have tried to start with a ne blank HA installation and curiously the cast are present. The problem seem to provide from deps chromecast libs and the new cast firmware. If I try to remplace the deps folder the visible casts disapear. So I have tried the cast curl command identification like : curl and the response isn’t valid the cast doesn’t return a full valid description without error

See here:

It happened to me a few times where I didn’t realized I have “cast” devices specified in the configuration.yaml file with specific iP addresses… could it be (if you haven’t checked) that the IPs on yours are changed???

My Cast IPs are fixed by my router. Discovery doesn’t work for me because I run HomeAssistant in Docker. There’s an issue with the latest Cast firmware that is fixed in the link above.

Hi I have tried the bump : pip3 install pychromecast==1.0.2 and restarted HA but I can’t see my cast anymore!
So could you explain to me more what is PR. I have never used a Pull Request on my HA and I would like to resolve the bug without PR.

I don’t know. I’m waiting for the next HomeAssistant release incorporating the PR.