CIFS Mounting


I have managed to configure some shell commands that seem to successfully mount some CIFS shares I have running on a macOS Server that I use to store my media files.

The shell commands look like this:


'mkdir /media/TV;mount -t cifs -o noserverino,username=username,password=password,uid=1001 //IP/TV /media/TV'


I know that the command has worked because if I look in the media browser I can see the existing media files there (created from a previous system), however at the command line (Using the advanced SSH terminal) I cannot see any files listed in the mounted folder.

I have also tried to use these mounted folders in some add-on’s I am running, whilst it can see the directories and write to them, the files the add-on creates (Sonarr) only appear on the home assistant machine and not on the actual network share.

I’m suspecting something to do with UID’s but even then I’m not sure, I can see the newly created files are owned by root on the HA server.

I’m running HaasOS 10.2 and Home Assistant 2023.5.4 with Supervisor 2023.04.1

Wait for the 2023.6 release later this week. It includes mounting network shares from the GUI.

1 Like