Home Assistant Community

Clas Ohlson WiFi Smart Plug

switch
Tags: #<Tag:0x00007f374edf67e0>
#1

Hi

I am trying to get the WiFi Smart Plug working on HA. I have got information that they are actually Broadlink devices, type: sp2. I can configure the IP address via Clas Ohlson Home app and I can control switch via CO Home app.
I get error Failed to connect to device after restart the HA. My configuration is very simple:
switch:

  • platform: broadlink
    host: 192.168.1.202
    mac: ‘78:0F:77:EB:8B:21’
    type: sp2
    friendly_name: ‘Kokeilu’
0 Likes

#2

Short update: the correct type seem to be sp3.
This works:
Selecting the Services menu:

The service dev tool allows you to call any available service in Home Assistant.

Palvelu
switch.turn_on

Kohde
switch.kokeilu

Service Data (JSON, optional)

{
“entity_id”: “switch.kokeilu”
}
Turn a switch on.
Parameter Description Example
entity_id
Name(s) of entities to turn on switch.living_room

1 Like

#3

Hello there.
I have the same plug but i can not see anywhere in the app where i can locate the IP adress.
Where did you go to get the Ip?

0 Likes

#4

Have a look at your router discovery - look for broadlink devices on the wifi. “broadlink outlet ***”

0 Likes