Clean Hassbian install - ssh connection reset

Just installed clean HASSBian 1.3.2 on rpi 3b+ but couldn’t get SSH to run.

the fix (from ):

log in directly using keyboard and monitor

sudo rm /etc/ssh/ssh_host*
sudo dpkg-reconfigure openssh-server

this deletes the faulty ssh keys and creates new ones.

Not sure if the faulty keys are in the image, or due to my inept installation however.

a brand new hassbian image shouldn’t have any SSH keys installed or necessary.

All you should have to do is find your IP address and log into a terminal session with user pi & password raspberry.

You will then need to set up your own SSH keys.

Unless something drastic has changed lately…

No idea - I downloaded the 1.3.2 image, wrote it to a new card, and plugged it in. It is possible I rebooted at the wrong time, but no reason that the ssh_host files on the system would have timestamps for March (rather than July), and a zero size.

But, it could have been me. Either way, this fix worked for me. And may help others.

I’d raise a possible issue against the project on github, but there isn’t an issues tag.

just rerolled the image (screwed something up) - worked first time. how strange.