Clean install Home Assistant Yellow with NVME wipe


I have Home Assistant Yellow POE kit. I have added CM4 4GB RAM/16GB eMMC and an NVME drive (970 EVO Plus MZ-V7S500 that is recommended on FAQ page).

I was experimenting a bit with installation, disk, partitions and I now I want to start fresh so I want to clean install Home Assistant on my device. I used option 1 from the official installation guide (link). I am doing all the steps, getting correct led behaviour, but for the love of God I can’t wipe the NVME and I keep booting to the old installation. Is using option 2 (rpiboot) the only way I can do it? Am I missing any steps other than doing the red + blue button to to clean install with wipe of the drives?

With problems above I looked around the guides and documentation. According to the reinstall page linked above, boot order should be eMMCNVMe SSDUSB flash drive. So I thought that I remove the NVME, install HA to eMMC, reinstall the drive and from ssh terminal I’ll be able to wipe the NVME so I can move the files there. I tried that but it doesn’t work as I expected and once I install the NVME I boot to old installation.

I saw that you can press blue button within 5 seconds of booting to installer, to directly install to NVME. I tried that and indeed it installed to the NVME. But in System > Hardware > All Hardware I can’t see my Samsung drive (I don’t know if I should but I saw some YouTube videos that people had them displayed there). Also I don’t know if this method is equivalent to doing the “Move datadisk” option from Storage menu? When I try that I see that it shows my NVME as the current and allows me to move to NVME:

So beside the main question here being is there a way to wipe my eMMC and NVME and do a clean install (on either) I have two more if you don’t mind addressing.

  • Is installing directly to NVME equivalent of doing “Move datadisk”?
  • Can I under-provision a drive and use it as target of “Move datadisk”? Let’s say setup 500GB NVME to 100GB partition?

Any ideas would be appreciated :slight_smile:

Thank you in advance,

Ok. Since I wanted to move on I just wiped the disk using some NVMe adapter on my PC.

I can also answer some of my own questions.

Advanced installation directly to NVMe (using blue button during 5s window as per documentation) is not equivalent of doing “Move datadisk”. The later moves just hasa-data to the drive while the first option outs everything including boot etc on the NVMe.

As for underprovisioning, still didn’t get too far with that as I have problems “seeing” the drives. I don’t see them in “All hardware”, not using fdisk -l. When I connect the drive to PC using adapter I also can’t see the partition as it is displayed as “unallocated”. Generally “All hardware” doesn’t show tak o much on Yellow, strange given it’s designed for Home Assistant.