CLI not starting on new install

You can’t ping a url. Try pinging the host.

Are you running into github rate limiting?

I’m not sure. how would I know that?

First of all you have two different problems.

  1. The original one where you cannot get the cli running. Post a comment to the issue what I linked about that. Angers might can point you to the right direction what can cause that.
  1. You have the problem of updating to 6.1 from 4.15. It is different from the first one (probably). As you described you are seeing a blank screen only after reboot. This is what you need to open a ticket about.

If I would be you, I would start from scratch, burn a new image with 6.1 and try to boot it, and if it fails to boot and get HA running, then I would collect all the logs what I can and needed for a bug report and I would open an issue.

If by just installing 6.1 from scratch you can see the same issue as the original one, then I would just put my RPi into my pocket and I would visit a friend who has different ISP and router and I would try to update there. Not a fancy and techie solution but can solve your issue. (The person in the aforementioned issue solved the problem by using a VPN, what is kinda using a different ISP. A VPN would give you a different public IP, what can be useful if @nickrout is right and you are hitting a github or docker rate limit. But I am just guessing.)

Regarding the ISP blocking something. If you have never seen any website blocked by your ISP, then it is probably safe to say, that your ISP is not blocking it.
If something is blocked by the ISP, you would see a website instead the one you wanted to visit, which would tell you that it has been blocked for X or Y reason.

Thank you. I will post in that link you provided and open a ticket.

I have already tried (many times) to start from scratch with 6.1, with the same issue. I do have a neighbor with a different ISP who I can probably use, but won’t see them till Tuesday. So if I don’t get things worked out over the weekend, I will try that route.

Will follow up here with any results.

Upon searching the bugs, it seems that someone has already described the issue here perfectly, and it is affecting many other pi 3B+ users.

Not sure what’s causing it, but something changed and caused this issue after 4.15/4.16.

1 Like

So I appear to be having the same issues, however I’m trying to create a VM on a Proxmox server, following the example in the link below. I’ve followed the same diagnostics as ezankel and had identical results, so whatever is causing it, I’m not sure it’s RPi related.

1 Like

Exactly Same for me trying a new install on raps pi4 8gb

I actually am running into this myself. So it’s not an isolated problem

1 Like

So I managed to get it working. I had to get into the command line and use nmcli to change my DNS using

nmcli con mod <connectionName> ipv4.dns "8.8.8.8 8.8.4.4"

then ignore the auto DNS using:

nmcli con mod <connectionName> ipv4.ignore-auto-dns yes

Where your connection name is whatever pops up when you do a nmcli con.

3 Likes

where did you change your dns?

Update: Workaround!!
@ewkinder, I was about to come on and report that I had success as well after changing the ipv4 dns for the default wired connection. Mine now works after changing the DNS to 1.1.1.1, even on Wifi.

@raidnet-ms wait until your system errors and looks like this:

Waiting for the Home Assistant CLI to be ready...
[WARN] Home Assistant CLI not starting! Jump into emergency console…
#

Then I would follow what @ewkinder did.

If you’re not sure about your connection name, look at my directions below for the commands.


My method:
I took a different route to accomplish the same system changes and accomplished the same result:
First, find out what your connection name is, so that you can change the DNS:
nmcli con show
In my case, the eth0 default connection name is “Home Assistant OS default”. It is highlighted in green

Then type:
nmcli con edit "Your Connection Name" to enter edit mode for that connection. If your connection has spaces like mine, make sure to put it between the quotation marks.

nmcli> print ipv4 will show you the ipv4 properties of that connection

Set the DNS server and local gateway while you’re here.

nmcli> set ipv4.dns 1.1.1.1
nmcli> save
nmcli> quit

After saving and leaving the nmcli editor, reboot your machine:
# reboot

If this doesn’t work, try activating Wifi and connecting that way first using the instructions here: Guide: Connecting Pi with Home Assistant OS to wifi (or other networking changes)


This seems to be an issue with the way that the default DNS is set up. What I was missing before was that I was not setting the DNS specifically for the connection, but the system as a whole. Once forcing it to use google or cloudflare dns, everything booted up perfectly after a restart. I haven’t had time to submit the bug yet, but I’m convinced that some time after 4.15, the default network settings changed, and for whatever reason they don’t work as well for Pi3B+.

3 Likes

Well thanks for the details.

I have 2 rasp pi4 8gb, the first was installed with hassio 4.X with conf file so I didn’t have any problem.

I’ve also tryed with hassio 5.9 and this version can be seen on homeassistant.local but the installation is stuck there.

I will try with your suggestion but first of all I want to try on a different ISP.

Do you think that this could be related with Zeroconf?
They updated it with 6.1

Do you think this is related with the same problem? Can’t connect to HA via homeassistant.local:8123 - Home Assistant OS - Home Assistant Community (home-assistant.io)

@ezankel, please post a link to the GitHub issue about your solution recorded here. The developers will might have an idea what to look for to fix it.

I don’t know if I Actually fixed mine but I am running my Pi 4 headless and don’t have any USB keyboards lying around so I added the ssh text file to the root of the SD card (as you would for other Pi installs)…when I put the card back in the pi it booted all the way up and I can now access. Before this I had taken the card out several times and performed various troubleshooting steps so I know it wasn’t a bad connection on the card…just another thing to try for those who are still struggling with this.

Sure you can also configure the network with a text conf file and it will load the settings on the boot.

Mmmm I can’t see any solution for this in the last changelog…

Issue has been updated with my notes and link to this thread.

I think this is the right one… someone correct me if not.

2 Likes

I got mine setup last night for the first time and was running into this same issue. Restarted a few times before I just logged in as root and checked the container logs with docker logs $(docker ps -q) and found that it was timing out trying to pull another image. Then I checked /etc/resolv.conf to find that only 192.168.0.1 was listed, so I added 8.8.8.8 and 8.8.4.4 following these instructions (below) as directly editing the file would simply result in it being overwritten by network manager. Once updated I restarted and it has been working since.

https://serverfault.com/questions/810636/how-to-manage-dns-in-networkmanager-via-console-nmcli

I was able to finish the installation from another location with a different ISP.

Same network config, same dns.