CLI not starting on new install

I am running a Raspberry Pi 3 B+. After the update to 6.1 hosed my install, I figured I’d get a fresh build running and restore my data.

However, each new boot fails. Everything seems to work fine- no errors pop up on the screen. Eventually it says “Waiting for the Home Assistant CLI to be ready…” which I’d expect. However, after some time a new message comes up on the screen plugged into the Pi:
“[WARN] Home Assistant CLI not starting! Jump into emergency console…”

No number of reboots fixes this issue, and search doesn’t reveal this to be a common message. If I type “login”, it refreshes the screen, starting with “waiting for the Home Assistant CLI to be ready”, but after some amount of time the same [WARN] message comes up again.

My router sees the Pi on the network, and I can ping it. However, there is no GUI or method to login.

This is happening with a fresh flash, using the 6.1 build following the directions on the website (using Balena Etcher) on a 128gb u3 SD card. I’ve tried a different SD card with the same results. 6 separate flashes, two of which were left for 4+ hours before attempting to reach the CLI/GUI. No change.

I am not familiar with the emergency console and very lost/frustrated. Any help is greatly appreciated

2 Likes

Did you download the correct image file for the pi3B+ ?

I believe so, as long as the links to the Pi3 images on the instructions website are correct. I tried both 64 and 32 bit with the same result.
Here are the links that I used:
https://github.com/home-assistant/operating-system/releases/download/6.1/haos_rpi3-64-6.1.img.xz
https://github.com/home-assistant/operating-system/releases/download/6.1/haos_rpi3-6.1.img.xz

1 Like

Ok, just making sure.

Same here. Go away for awhile–mine took a half hour on a pi4-4g. Login has moved to tty1. Try ctrl-alt-f2 or greater for root login screen.

1 Like

I tried this - left it overnight last night. Same issue

Update: Still no fix. I have tried two different SD cards, (32gb, 128gb) and even bought an enclosure for a brand new m.2 ssd I had lying around. All seem to start the install process fine, but came up with the exact same error:

“[WARN] Home Assistant CLI not starting! Jump into emergency console…”

It sure seems like something is broken on these when installing on the 3B+.

Not sure how to get any more information or check logs from the emergency console. All suggestions are welcome.

Inadequate power supply maybe?

I am having the same issue and tried the same things.

1 Like

did you try this?

I’ve the same issue on PI3

1 Like

Yes, I tried that and it allows me to login as root. I ran systemctl status systemd-timesyncd.service and it appears that the timesync did occur just fine (i read on another thread that sometimes a failed time sync caused some issues in the past)

next i tried running ‘ha’ to see if it would come up.

# ha
Error: No such container: hassio_cli
#

It appears that the CLI did not install at all?

Is the ui coming up in a browser in another device?

What does docker ps -a tell you?

No it is not.

docker ps -a gets me

IMAGE: homeassistant/aarch64-hassio-supervisor:latest
COMMAND: "/init"
CREATED: 2 days ago
STATUS: Up 19 minutes
PORTS: <blank>
NAMES: hassio_supervisor
1 Like

Something has certainly failed!

What should it say?

There should be about half a dozen containers there. At the least

the core (probably named something-homeassistant:2021.6.6)
hassio-observer
hassio-dns
hassio-multicast
hassio-cli
hassio-audio

Try docker pull hassio-cli

Okay: that results in this:

#docker pull hassio-cli
using default tag: latest
Error response from daemon: Get "https://registry-1.docker.io/v2/": net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Maybe you don’t have a network connection. ping 8.8.8.8
ping google.com

both are alive.

I can also ping the device on my network