Climate entity with dynamic target

Hi folks

I want to have all climate entity with a dynamic target temperature

I tried
target_temp: {{ states ('sensor.fussbodenheizung_soll) | float(0) }}
but it ends in an error

Asside from that I want to show the controller output level.
It is also a sensor value

All these values are from my heater.
I don’t want to control anything. Just show the values in a climatecontroller graphic card


Where did you try this and what was the complete error text?

I tried this in configuration.yaml under climate

Here ist the full entry:

  - platform: generic_thermostat
    name: heatronic_fbh
    heater: binary_sensor.heizungsbrenner
    target_sensor: sensor.fussbodenheizung_istwert
    target_temp: {{ states ('sensor.fussbodenheizung_sollwert) | float(0) }}
    min_temp: 20
    max_temp: 45

and here ist the errortext

Error loading /config/configuration.yaml: invalid key: “{“states(‘sensor.fussbodenheizung_sollwert’) | float(0)”: None}” in “/config/configuration.yaml”, line 464, column 0

That option does not accept templates. Unless an option specifically lists templates in its documentation, then it does not.

You will have to automate this.

Trigger on any state change of your sensor and set the temperature in the action.

How can I do this?

alias: Sollwertupdate
description: ""
  - platform: state
      - sensor.fussbodenheizung_sollwert
condition: []
  - service: climate.set_temperature
      value: sensor.fussbodenheizung_sollwert
      entity_id: climate.heatronic_fbh
mode: single

What must bei in data?

Arent you missing a '
target_temp: {{ states('sensor.fussbodenheizung_soll') | float(0) }}

You could create a template sensor with that tho if its not supported in climate
Just listen to tom_I

  - service: climate.set_temperature
      value: "{{ states('sensor.fussbodenheizung_sollwert') }}"
      entity_id: climate.heatronic_fbh

We may have to format this data if say your climate temperature only accepts integers and your sensor contains a value with decimal parts.

Also to prevent triggering on unknown states change your trigger to:

  - platform: state
      - sensor.fussbodenheizung_sollwert
      - unknown
      - unavailable 
1 Like

Doesn’t matter if the template is correct or not. That option still won’t accept a template.

Also how does creating a template sensor help with adjusting the temperature?

The automation now works.
…but IT doesn’t update the value in the climate entity

Now it works.
I have to use temperature instead of value

1 Like

I think i’m having a litlle brain fart. After rereading this on the computer instead of phone i see my reply does not make sense apart from the missing ’ which doesnt matter in the end. Blame it on waking up so soon for F1 :sleepy:

1 Like