Climate Step

Hi, I am trying to change my generic thermostat “step” argument to 0.5 but it is not registering. I have tried to delete the compile directory. Restart AppDaemon. Different argument values. Nothing. Any advice?

i just checked because i never used climate but it seems like step is set in the code to 1
so the option to set the step is not active.

i dont know if @aimc had planned to put it in and forgot, or if it was in there but didnt work with HA and he took it out but forgot to change the docs.

Yes, it’s on my list to fix …

1 Like

Thanks for the quick replies!

Also, unrelated to climate (kinda), is there a way to not show certain dark sky parameters in the weather widget? Like only the current temperature? Is there also a way to change what the parameters are named? Like change “Apparent Temp” to “Feels Like”?

Thanks again!

  1. create a dir called conf/custom_widgets
  2. copy the dir baseweather from the widgets dir to that new dir
  3. copy weather.yaml to that same dir
  4. change the HTML file in the baseweather dir

and before i forget:

dont forget to read about creating custom widgets in the docs:

is this already fixed?

I merged a PR for it yesterday, still testing, but this will be in 3.0 Beta 3 in a week or two.

Still appears unfixed.

no it is fixed and should work.

Odd, still doing 1 degree steps only for me, regardless of what i put in as “step”.
I’ll poke around some more.

which version from AD?
what system (hasbian, docker, hassio, venv, …)?
do you have custom widgets?
what is in your dashboard file?

Hasbian. AD 3.0.1, no custom widgets.
Relevant part of the dashboard file:

  widget_type: climate
  entity: climate.termostat
  title: Termostat
  step: 0.5
  level_style: "margin-top:-5px; color: white"
  unit_style: "margin-top:0px; color: white"
  level2_style: "font-size: 140%; color: white"
  unit2_style: "font-size: 70%; margin-top: 3px; margin-left: 3px; color: white"
  level_down_style: "font-size: 150%; color: white"
  level_up_style: "font-size: 150%; color: white"
  widget_style: "background-color: #3ca916"

Actually, scratch that…
Rebooted and now it’s fine o_O

I’ve previously tried restarting AD only and it kept doing 1 degree increments.
Now i’ve rebooted the machine and it’s suddenly fine.

Sorry for the fuss!

no problem.
probably something in HA that didnt accept it at that point.

I tried your code about climate widget, but i cannot get the units displayed…

This is what i get:


How to have also the units in the widget?

do you have a generic thermostat?
it was an oversite that the units cant be set in the dashboard.
it gets retrieved from HA, but only if HA sets it, and the generic doesnt set it as attribute.

No, my thermostat is a Tado and i see the attributes in HA have no units… so it’s clear now !